Closed Bug 1285240 Opened 3 years ago Closed 3 years ago

trim leading and trailing space from link text when finding elements

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(firefox49 fixed, firefox50 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: automatedtester, Assigned: automatedtester)

References

()

Details

Attachments

(2 files)

In FirefoxDriver they strip the leading and trailing white space when searching for link text elements

I have updated the spec in https://github.com/w3c/webdriver/pull/312
Assignee: nobody → dburns
This gives up parity with the WebDriver project and brings us in line with the current
specification http://w3c.github.io/webdriver/webdriver-spec.html#dfn-link-text

Review commit: https://reviewboard.mozilla.org/r/62948/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/62948/
Attachment #8768970 - Flags: review?(ato)
Attachment #8768971 - Flags: review?(ato)
The tests had the same name which caused a redefinition meaning only one of the tests
was run.

Review commit: https://reviewboard.mozilla.org/r/62950/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/62950/
Duplicate of this bug: 1283691
Comment on attachment 8768971 [details]
Bug 1285240: Update tests to prevent redefinitions

https://reviewboard.mozilla.org/r/62950/#review59898
Attachment #8768971 - Flags: review?(ato) → review+
Comment on attachment 8768970 [details]
Bug 1285240: Trim leading and trailing space when finding elements by link text

https://reviewboard.mozilla.org/r/62948/#review59900
Attachment #8768970 - Flags: review?(ato) → review+
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e7d0a3aab62
Trim leading and trailing space when finding elements by link text r=ato
https://hg.mozilla.org/integration/autoland/rev/0ac60b8ebc49
Update tests to prevent redefinitions r=ato
Sheriffs, once this hits central please can you uplift all the way to beta
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
https://hg.mozilla.org/mozilla-central/rev/5e7d0a3aab62
https://hg.mozilla.org/mozilla-central/rev/0ac60b8ebc49
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Whiteboard: [checkin-needed-aurora][checkin-needed-beta] → [checkin-needed-beta]
has problems to apply to aurora:

David could you take a look, thanks!

grafting 353324:5e7d0a3aab62 "Bug 1285240: Trim leading and trailing space when finding elements by link text r=ato"
remote changed testing/marionette/harness/marionette/tests/unit/test_element_retrieval.py which local deleted
use (c)hanged version, leave (d)eleted, or leave (u)nresolved? c
merging testing/marionette/element.js
warning: conflicts while merging testing/marionette/element.js! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(dburns)
Whiteboard: [checkin-needed-beta]
I landed this myself
Flags: needinfo?(dburns)
You need to log in before you can comment on or make changes to this bug.