Closed Bug 1285393 Opened 4 years ago Closed 4 years ago

[encoding] href handling

Categories

(Core :: DOM: Core & HTML, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1225255

People

(Reporter: addison, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

The W3C I18N WG in cooperation with WhatWG has created tests for the Encoding specification. In the course of testing, we found that the encoding done in hrefs is not consistent with the HTML specification or with what other browsers do. This causes Firefox to fail all of the href encoding tests.

The problem is that instead of following the character encoding of the page, the href encodes the Unicode (UTF-8) byte sequence.


Actual results:

https://github.com/whatwg/encoding/issues/62
https://github.com/whatwg/encoding/issues/61
https://github.com/whatwg/encoding/issues/60
https://github.com/whatwg/encoding/issues/59
https://github.com/whatwg/encoding/issues/58
https://github.com/whatwg/encoding/issues/57
https://github.com/whatwg/encoding/issues/56


Expected results:

see above. Please also comment on one or more of the attached issues. If there are errors in our tests, we very much want to know.

[filed on behalf of W3C I18N WG]
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
Henri may have thoughts here given his related work.
Blocks: encoding
Sorry about the inconvenience. This is a know problem. At present, it's unclear if it should be fixed (bug 1225255) in our current URL parser or if we should wait for rust-url to land in Gecko. I started fixing bug 1225255 but I tried to do it too properly which made the scope of the fix get too large. I suppose a small fix without any additional clean-ups would be good.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1225255
Henri, what's the expected timeframe for the introduction of rust-url?  I'm thinking that if it's only weeks away it's best to put the effort into that, since that's really the fix that's needed.
I expect rust-url to be more than a few weeks away. Let's get this aspect of the current URL parser fixed over in bug 1225255.
You need to log in before you can comment on or make changes to this bug.