[e10s] Developer Tools are automatically dismissed and unable to be relaunched via keyboard shortcuts when navigating to any URL from a blank page

RESOLVED DUPLICATE of bug 1068400

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 1068400
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

({regression, regressionwindow-wanted})

Trunk
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 wontfix, firefox49 fix-optional, firefox50 wontfix)

Details

(Reporter)

Description

2 years ago
[Affected versions]:
- Firefox 48 beta 6 (Build ID: 20160706215822)
- latest Aurora 49.0a1
- latest Nightly 50.0a1
* reproducible only with e10s enabled

[Affected platforms]:
- Windows 10 64-bit
- Mac OS X 10.9.5
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Launch Firefox.
2. In about:preferences, set 'When Firefox starts:' to 'Show a blank page'
3. Close and reopen Firefox.
4. Open Inspector: Ctrl + Shift + C (for Windows & Ubuntu) or Cmd + Opt + C (for Mac OS X)
4.1. Dismiss the Developer Edition promo (Beta only).
5. Click anywhere in the Markup View.
6. Navigate to any webpage (E.g.: http://www.bbc.com/)
7. Open Inspector via keyboard shortcut (as in step 4)

[Expected result]: 
- The Inspector is opened.

[Actual result]: 
- At step 6: The Inspector is automatically dismissed.
- At step 7: The Inspector is not opened.

[Regression range]: 
- This looks like an old regression: reproducible with 44.0a1 (from 2015-10-01), but not with 36.0a1 (from 2014-11-07) when e10s was enabled by default; will investigate further.

[Additional notes]:
- Screen recording: https://goo.gl/douFBD
- This is applicable for every keyboard shortcut displayed in Developer option via the Menu Panel.
IIRC the start page is non-e10s and we don't support switching the toolbox from non-e10s mode to e10s mode (or vice versa).  See Bug 1068400: we are hoping that about:newtab can be converted into the content process so this issue goes away.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068400
Wontfix for 48 here and in the original, we could still take a patch in 49 though.
status-firefox48: affected → wontfix
status-firefox49: affected → fix-optional

Comment 3

2 years ago
Too late to fix in 50.1.0 release
status-firefox50: affected → wontfix
You need to log in before you can comment on or make changes to this bug.