Implement PushSubscriptionOptions.userVisibleOnly

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: johnme, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I noticed that Firefox 48 does not implement the userVisibleOnly attribute of the PushSubscriptionOptions interface.
https://w3c.github.io/push-api/#pushsubscriptionoptions-interface-and-dictionary

It's fine for UAs to ignore the value of the userVisibleOnly property of the PushSubscriptionOptionsInit dictionary, but the spec as currently written implies that UAs should nevertheless reflect the value back in the PushSubscriptionOptions interface.
Thanks! This means we'll want to store the value that the user passes in for `userVisibleOnly`, right? (Even if we don't use it for anything else).

I'm a bit wary because we treat `.subscribe({ userVisibleOnly: true })` and `.subscribe({ userVisibleOnly: false })` the same way, so it's unclear what `userVisibleOnly` would mean in Firefox. Maybe we can use it to enforce a stronger quota, though?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'd rather have the spec amended to allow UAs to only include the properties that it implements.
(In reply to Martin Thomson [:mt:] from comment #2)
> I'd rather have the spec amended to allow UAs to only include the properties
> that it implements.

So should we close this and use a spec issue instead?
Flags: needinfo?(martin.thomson)
Priority: -- → P3
https://github.com/w3c/push-api/issues/200
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(martin.thomson)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.