Firefox 47 does not clear graphics properly in Toolbar

RESOLVED DUPLICATE of bug 1279677

Status

()

Core
Graphics
--
minor
RESOLVED DUPLICATE of bug 1279677
2 years ago
2 years ago

People

(Reporter: Nikita Yerenkov-Scott, Unassigned)

Tracking

47 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
I have found that in Firefox 47 (currently the latest) that when for instance the star animation is playing for the bookmarks button in the Toolbar or when the downloads animation is playing when a download finishes that it leaves some of the graphics behind. This often happens, but not always.

Here are some example screenshots:

    Firefox_Star_Issue.png
    Firefox_Download_Issue.png

And there is nothing seemingly I can do to get rid of these annoying graphics (I have not tried replaying the animations again, but I will update this report when I have tested that).

I am running Ubuntu GNOME 16.04 with GNOME 3.20.

I initially reported this issue here, but thought I should also do so upstream: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1600650
(Reporter)

Comment 1

2 years ago
Created attachment 8769513 [details]
Firefox_Star_Issue.png
(Reporter)

Comment 2

2 years ago
Created attachment 8769514 [details]
Firefox_Download_Issue.png
Does this happen if you restart Firefox in safe mode? Can you post the contents of about:support (help > troubleshooting information) ? Can you also test an official mozilla.org binary instead of your distribution's copy if you haven't already done so?
Component: Toolbars and Customization → Graphics
Flags: needinfo?(cooks.go.hungry)
Product: Firefox → Core
(Reporter)

Comment 4

2 years ago
I have not yet tested this in safe mode, nor with an official Mozilla binary, but I will do that as soon as I can and get back to you on it.

Currently though I can only provide you with the about:support page information you requested:

Application Basics
------------------

Name: Firefox
Version: 47.0
Build ID: 20160607113630
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
OS: Linux 4.4.0-28-generic x86-64
Multiprocess Windows: 0/2 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.7.3
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Firefox Hello
Version: 1.3.2
Enabled: true
ID: loop@mozilla.org

Name: Ghostery
Version: 6.3.1
Enabled: true
ID: firefox@ghostery.com

Name: HTTPS-Everywhere
Version: 5.1.10
Enabled: true
ID: https-everywhere@eff.org

Name: Mailvelope
Version: 1.5.1
Enabled: true
ID: jid1-AQqSMBYb0a8ADg@jetpack

Name: Multi-process staged rollout
Version: 1.0
Enabled: true
ID: e10srollout@mozilla.org

Name: NoScript
Version: 2.9.0.11
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Pocket
Version: 1.0.2
Enabled: true
ID: firefox@getpocket.com

Name: TrafficLight
Version: 0.2.23.1-signed.1-signed
Enabled: true
ID: trafficlight@bitdefender.com

Name: uBlock Origin
Version: 1.7.6
Enabled: true
ID: uBlock0@raymondhill.net

Name: Ubuntu Modifications
Version: 3.2
Enabled: true
ID: ubufox@ubuntu.com

Name: uMatrix
Version: 0.9.3.6
Enabled: true
ID: uMatrix@raymondhill.net

Name: VTzilla
Version: 1.5.1-signed.1-signed
Enabled: true
ID: info@virustotal.com

Graphics
--------

Adapter Description: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
Asynchronous Pan/Zoom: none
Device ID: Mesa DRI Intel(R) Sandybridge Mobile
Driver Version: 3.0 Mesa 11.2.0
GPU Accelerated Windows: 0/1 Basic (OMTC)
Supports Hardware H264 Decoding: No
Vendor ID: Intel Open Source Technology Center
WebGL Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
windowLayerManagerRemote: true
AzureCanvasAccelerated: 0
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
CairoUseXRender: 0

Important Modified Preferences
------------------------------

accessibility.blockautorefresh: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 0
browser.cache.disk.enable: false
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20160607113630
browser.startup.homepage: https://mail.google.com/mail/u/0/#inbox|https://askubuntu.com/questions|https://chat.stackexchange.com/
browser.startup.homepage_override.buildID: 20160607113630
browser.startup.homepage_override.mstone: 47.0
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 47.0
font.internaluseonly.changed: true
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1463336050
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160607113630
media.gmp-manager.lastCheck: 1468263194
media.gmp.storage.version.observed: 1
media.peerconnection.ice.default_address_only: true
network.cookie.cookieBehavior: 1
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1468091056
places.history.expiration.transient_current_max_pages: 99698
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.clearOnShutdown.cookies: false
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.formdata: false
privacy.clearOnShutdown.history: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.sanitizeOnShutdown: true
security.ssl.errorReporting.automatic: true
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1466011300

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.23 Basic ECC
Version in use: 3.23 Basic ECC

NSSSMIME
Expected minimum version: 3.23 Basic ECC
Version in use: 3.23 Basic ECC

NSSSSL
Expected minimum version: 3.23 Basic ECC
Version in use: 3.23 Basic ECC

NSSUTIL
Expected minimum version: 3.23
Version in use: 3.23

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronisation: true
User Namespaces: true
Media Plugin Sandboxing: true
Whiteboard: [gfx-noted]

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(cooks.go.hungry)
Resolution: --- → DUPLICATE
Duplicate of bug: 1279677
You need to log in before you can comment on or make changes to this bug.