[e10s-multi] Print preview seems to be broken with multiple content processes

RESOLVED DUPLICATE of bug 1142013

Status

()

RESOLVED DUPLICATE of bug 1142013
2 years ago
2 years ago

People

(Reporter: gkrizsanits, Assigned: mrbkap)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [e10s-multi:M1])

(Reporter)

Description

2 years ago
With multiple content processes for browser/base/content/test/general/browser_printpreview.js I see the following error on the console and then the test times out:

4 INFO Console message: [JavaScript Error: "[Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIPrintSettingsService.defaultPrinterName]"  nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :: chrome://global/content/browser-content.js :: getPrintSettings :: line 482"  data: no]"]
5 INFO Console message: [JavaScript Error: "[Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIWebBrowserPrint.printPreview]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://global/content/browser-content.js :: enterPrintPreview :: line 621"  data: no]"]
(Reporter)

Updated

2 years ago
Blocks: 1207306
Whiteboard: [e10s-multi:M?]
tracking-e10s: --- → ?
(Reporter)

Updated

2 years ago
tracking-e10s: ? → ---
Depends on: 1142013
This should be fixed by making print preview open in the same process.
Assignee: nobody → mrbkap
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [e10s-multi:M?] → [e10s-multi:M1]
Duplicate of bug: 1142013
You need to log in before you can comment on or make changes to this bug.