Add-on recommendation engine should be trained using add-on ids instead of add-on names

RESOLVED FIXED

Status

Cloud Services
Metrics: Pipeline
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: rvitillo, Assigned: Dexter)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [measurement:client])

Attachments

(1 attachment)

Comment hidden (empty)

Updated

a year ago
Points: --- → 1
Priority: -- → P2
(Assignee)

Updated

a year ago
Assignee: nobody → alessio.placitelli
Priority: P2 → P1
(Assignee)

Updated

a year ago
Whiteboard: [measurement:client]
(Assignee)

Updated

a year ago
Points: 1 → 3
(Assignee)

Comment 1

a year ago
I've been working on that lately, and discovered quite a few interesting things.

- The id of a signed addon can be associated to different names (an addon can change its name during its lifetime).
- Unsigned addons can share the same addon id, even if they are totally different.
- The latest name for a particular, signed and reviewed addon could be retrieved using the API documented at [1] given its addon id.

[1] - http://addons-server.readthedocs.io/en/latest/topics/api/addons.html#detail
(Assignee)

Comment 2

a year ago
PR: https://github.com/mozilla/telemetry-batch-view/pull/97
(Assignee)

Comment 3

a year ago
Created attachment 8773838 [details] [review]
Train the model using addonIds
Attachment #8773838 - Flags: review?(rvitillo)
(Assignee)

Comment 4

a year ago
Also, some notes on the data on a.m.o. There are non-publicly available addons on AMO:

- it could be because the add-on has been disabled by the developer
- it coule be because it has been rejected
- it could be because it's unlisted - the developer has submitted it to AMO for it to be signed but does not want us to distribute it, they'll handle that themselves
- it could be because the developer started the submission process but didn't finish it (and thus we have incomplete information for the addon).

In all these cases, the public unauthenticated a.m.o API won't return the addon informations.
Alessio, please add Comment 4 as a comment in the code.
Priority: P1 → P2
(Assignee)

Updated

a year ago
Priority: P2 → P1
(Reporter)

Updated

a year ago
Attachment #8773838 - Flags: review?(rvitillo) → review+
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Duplicate of this bug: 1284520
You need to log in before you can comment on or make changes to this bug.