Closed Bug 1286348 Opened 4 years ago Closed 4 years ago

Reintroduce support for UNPACK_FLIP_Y and UNPACK_PREMULTIPLY_ALPHA for WebGL2

Categories

(Core :: Canvas: WebGL, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

Attachments

(2 files)

No description provided.
These patches are exciting, because:

$ git diff --stat HEAD~2
 dom/canvas/TexUnpackBlob.cpp      | 928 +++++++++++++-------------------------
 dom/canvas/TexUnpackBlob.h        |  82 ++--
 dom/canvas/WebGLContext.h         |  24 +-
 dom/canvas/WebGLContextUtils.cpp  |  18 +-
 dom/canvas/WebGLTexture.h         |   3 +
 dom/canvas/WebGLTextureUpload.cpp | 138 +++---
 6 files changed, 430 insertions(+), 763 deletions(-)
Well, windows hasn't come back yet, but it was green before. "likely green"
Duplicate of this bug: 1266664
Comment on attachment 8770263 [details]
Bug 1286348 - Reintroduce support for UNPACK_{FLIP_Y,PREMULTIPLY_ALPHA}. -

https://reviewboard.mozilla.org/r/63758/#review60938
Attachment #8770263 - Flags: review?(mtseng) → review+
Attachment #8770264 - Flags: review?(mtseng) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d95a6d08558
Reintroduce support for UNPACK_{FLIP_Y,PREMULTIPLY_ALPHA}. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/b15f05a94c71
Only set ROW_LENGTH if it's different. - r=mtseng
https://hg.mozilla.org/mozilla-central/rev/8d95a6d08558
https://hg.mozilla.org/mozilla-central/rev/b15f05a94c71
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Depends on: 1281098
Blocks: 1286758
Depends on: 1322691
No longer depends on: 1322691
Blocks: 1322169
No longer blocks: 1322169
Depends on: 1322169
Depends on: 1330672
You need to log in before you can comment on or make changes to this bug.