Closed Bug 1286428 Opened 4 years ago Closed 11 months ago

Remove printer information entries from "Important Modified Preferences" in about:support

Categories

(Toolkit :: General, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: human.peng, Assigned: standard8)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

Doesn't feel they're "important" and they are normally A LOT of entries (my profile have 126 entries starting with "print.printer", which makes the list very hard to read.
Hi Mike, 

Any thoughts on this? Is printer information something that can be removed from "Important Modified Preferences" in about:support?
Component: Untriaged → General
Flags: needinfo?(mbeltzner)
I don't think Mike's around, 302 Dolske.
Flags: needinfo?(mbeltzner) → needinfo?(dolske)
Speaking as somebody who's triaged / dealt with printing related bugs in the past year for e10s stuff, I don't recall a single instance where the printing information has ever proven particularly useful.
I know bobowen has also done some printing work recently - more in the backend. Has that section of about:support ever proven useful to you, bobowen?
Flags: needinfo?(bobowen.code)
The printer prefs came in with the initial list of whitelisted prefs (bug 554174). I'd agree that they don't seem super-useful.

It's probably more useful to check with someone that deals with SUMO support requests, but I'd generally expect that printing-related stuff is of such a narrow focus that this can just be removed.
Flags: needinfo?(dolske)
(In reply to Mike Conley (:mconley) - (Needinfo me!) from comment #4)
> I know bobowen has also done some printing work recently - more in the
> backend. Has that section of about:support ever proven useful to you,
> bobowen?

Once I think, but I appreciate that it probably adds a lot of noise.
Flags: needinfo?(bobowen.code)
Priority: -- → P3
Product: Firefox → Toolkit
Duplicate of this bug: 1335728
Duplicate of this bug: 951420

Personally I've never used these printer prefs to troubleshoot but perhaps our fab SUMO Firefox support volunteers have?!?! So I asked in our SUMO contributor forum:

Follow-up from the SUMO forum is that there isn't a major need to keep these prefs. If there's an odd printing bug, then they can be asked for directly.

Assignee: nobody → standard8
Status: NEW → ASSIGNED

These are not generally used for support, and there can be many of them which makes the report larger and harder to understand.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad0434a3ac37
Stop reporting print.printer* preferences in about:support. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.