[Win10] Firefox tile from the start menu only shows 2 sizes instead of 4

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

Trunk
All
Windows 10
Points:
---

Firefox Tracking Flags

(firefox47 affected, firefox48 affected, firefox49 affected, firefox50 affected)

Details

[Affected versions]:
- latest 50.0a1 Nightly
- latest 49.0a2 Aurora
- Firefox 48.0b7
- Firefox 47.0.1

[Affected platforms]:
- Windows 10 x86/x64

[Steps to reproduce]:
1. Right click the Firefox executable and select "Pin to start".
2. Hit the windows key and right click the Firefox icon.
3. Select resize and pick one of the values.

[Expected result]:
- There are 4 sizes you can choose between: small, medium, wide and large.

[Actual result]:
- Tile in the start menu has only 2 sizes: small, medium

[Regression range]:
- This issue is not a regression.
Does this still happen on nightlies including bug 1232679?
Component: General → Shell Integration
Flags: needinfo?(cornel.ionce)
See Also: → bug 1232679
Cornel, are you sure that Firefox's start menu tile is able to be resized to wide and large? It doesn't look like Windows supports that for non-Microsoft apps:

https://msdn.microsoft.com/en-us/library/windows/apps/dn393983.aspx#Specify_images
(In reply to Katie Broida [:ktbee] from comment #2)
> Cornel, are you sure that Firefox's start menu tile is able to be resized to
> wide and large? It doesn't look like Windows supports that for non-Microsoft
> apps:
> 
> https://msdn.microsoft.com/en-us/library/windows/apps/dn393983.
> aspx#Specify_images

I can confirm that this is the expected behavior, thanks Katie!
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(cornel.ionce)
Resolution: --- → INVALID
This looks like it is not actually only for non-Microsoft apps, but only for Windows Store apps.
Per https://msdn.microsoft.com/en-us/library/windows/apps/dn393983.aspx,

Tile design best practices specify that if your tile is not a live tile, it should not claim the extra screen space required for wide (310x150) and large (310x310) tiles. Because a desktop app's tile is always static and never live, those additional tile sizes are not supported in this schema.
Blocks: 1232679
See Also: bug 1232679
You need to log in before you can comment on or make changes to this bug.