[Win10] Cortana search no longer works with Firefox

RESOLVED WONTFIX

Status

()

Firefox
Search
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

Trunk
All
Windows 10
Points:
---

Firefox Tracking Flags

(firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 wontfix)

Details

[Affected versions]:
- latest 50.0a1 Nightly
- latest 49.0a2 Aurora
- Firefox 48.0b7
- Firefox 47.0.1

[Affected platforms]:
- Windows 10 x86/x64

[Steps to reproduce]:
pre-requisite: make sure Cortana is enabled
1. Open Firefox and make it the default browser.
2. Perform a search with Cortana.

[Expected result]:
- The search results are displayed with Firefox and it's search engine.

[Actual result]:
- The search is performed with Edge with bing.

[Regression range]:
- This is not a Firefox regression, but it used to work on older Windows 10 builds.


[Additional notes]:
- I'm unable to determine the exact time when this stopped working since it will require a lot of time invested into installing several insider builds.
- Tested with Insider build 14388.
Is there something we can/should do about this?
Flags: needinfo?(dolske)
Further investigation proved that this bug is reproducible:
- with Insider Preview Build 14390 (latest as of today)
- on release builds of Windows 10 as well (e.g. 10586.494)
- with other browsers as well (e.g. Opera, Chrome)

From QE's perspective, this is an OS related shortcoming.
Directly from MS:
https://blogs.windows.com/windowsexperience/2016/04/28/delivering-personalized-search-experiences-in-windows-10-through-cortana/

> Starting today, to ensure we can deliver the integrated search experience designed for Windows 10,
> Microsoft Edge will be the only browser that will launch when you search from the Cortana box.
Yeah this is wonfix because Microsoft won't allow us to change this anymore. :sadface:
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dolske)
Resolution: --- → WONTFIX
Does this mean there's code that's now dead and that we can remove?
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> Does this mean there's code that's now dead and that we can remove?

Yes, filed bug 1287622 to remove it. Thanks for saying something :)
status-firefox47: affected → wontfix
status-firefox48: affected → wontfix
status-firefox49: affected → wontfix
status-firefox50: affected → wontfix
You need to log in before you can comment on or make changes to this bug.