Closed Bug 128688 Opened 20 years ago Closed 19 years ago

Accept Cookie dialog prevents interaction with other windows

Categories

(Core :: Networking: Cookies, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 65521

People

(Reporter: Biesinger, Assigned: morse)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020223
BuildID:    2002030122

While the accept cookie dialog is displayed, I am unable to interact with other
open Mozilla windows with the mouse. It works using the keyboard.

Reproducible: Always
Steps to Reproduce:
0. check the "Ask me before storing a cookie" checkbox
1. Visit a site which tries to set a cookie, e.g. the one given in the URL field
2. Switch to another window
3. Click on a menu, or scrollbar, or anything else which should do something

Actual Results:  The click is ignored

Expected Results:  pop up the menu, or scroll the page, or do whatever was
expected by that mouseclick
this is working fine for me on my winNT machine.  tever, can you reproduce?  Is 
this a linux-only problem?
no, I can not reproduce this on linux.  If I leave the "Confirm" that you want
the cookie set dialog open, my mouse still works with menus, scrolling etc in
other windows.

On winNT, I can do the same thing except I can not use the mouse to get back to
the mozilla window which is the parent of the "Confirm" dialog.  But I can
switch between all other open windows and use the mouse.  
I can still reproduce this.

Hm... maybe it's related to native GTK widgets... I'll check that.
no, it's not because of native gtk widgets.

I'll try a nightly now instead of my self-compiled mozilla...
Happens in nightly, too

(all my testing done on linux)
Nothing I can do about this if it can't be reproduced except by the reporter.  
Have to close this out as wfm.  Reporter, since you have your own build, can you 
do some debugging on this?  If so, then reopen the bug and assign it to 
yourself.  Thanks.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
I suspect this is a dup of bug 65521

reopening to mark as dup
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
yeah that patch fixed it.

*** This bug has been marked as a duplicate of 65521 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.