Status

()

Core
Editor
--
major
VERIFIED DUPLICATE of bug 107927
16 years ago
16 years ago

People

(Reporter: Mike Lee, Assigned: kinmoz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
build 2002030208

additional <br> tag is inserted if a <br> tag is on the last line switching from
source to normal mode.

steps to reproduce:
1.open composer (blank page), switch to source view
2.make <br> sit on the last line (insert it, or backspace </body></html>)
3.switch to normal then back

actual result: extra <br> inserted + bunch of linespace

expected result: nothing changes

Comment 1

16 years ago
In bug 114740 (comment 8), I read that serializer always adds a newline after a
<br>. This happens even if "pretty print" is not checked in Composer preferences
and I don't understand why. "Retain original source formatting" means that
manually entered html code should be left intact.

Comment 2

16 years ago
Dipa, didn't you file a bug onthe br insertion? is that a DUP of this bug ?

Comment 3

16 years ago
This bug is about added newlines when switching from html source view to normal
view. At least, this is what I understand from the original report. My bug is
about the <br> itself.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 107927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.