“Open Selected Links” WebExtension stopped working

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
2 years ago
2 years ago

People

(Reporter: shell, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

(Reporter)

Description

2 years ago
jst reported dveditz’ webextension based add-on “Open Selected Links” WebExtension stopped working.

Shell can't find that extension - so NIing dveditz for a link if i wrote the name down wrong.  Also what stopped working and do you have a timeframe for when it stopped.
(Reporter)

Updated

2 years ago
Blocks: 905436
Flags: needinfo?(dveditz)
https://addons.mozilla.org/en-US/firefox/addon/open-selected-links/

It stopped working for me, too. There were no visible errors, just the context menu item didn't show up. In today's nightly it was magically working again.

jst: Is it working for you now, too? Or is it just a flaky "sometimes it does" kind of thing?

[off topic for bug: kmag suggested that tab.executeScript() would be better than loading a content script in every page, but that's not the reason the context menus don't show up.]
Flags: needinfo?(dveditz) → needinfo?(jst)
(Reporter)

Comment 2

2 years ago
when the service worker issue was corrected - this and lastpass instantly started working again the day that patch landed.  believe that issue resolved this issue (of about 1.5 weeks)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Yup, all good on nightly now!
Status: RESOLVED → VERIFIED
Flags: needinfo?(jst)
You need to log in before you can comment on or make changes to this bug.