Closed Bug 1287310 Opened 3 years ago Closed 3 years ago

Fix asymmetry for new pane toggle

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(firefox50 fixed, firefox51 verified)

VERIFIED FIXED
Firefox 51
Tracking Status
firefox50 --- fixed
firefox51 --- verified

People

(Reporter: magicp.jp, Unassigned)

References

Details

Attachments

(7 files, 2 obsolete files)

Attached image pane-toggle.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160716030215

Steps to reproduce:

1. Start Nightly
2. Open DevTools > Inspector
3. Confirm the pane toggle


Actual results:

New pane toggle is not symmetry. Especially arrow.


Expected results:

Place arrow in the symmetry.
Component: Untriaged → Developer Tools
OS: Unspecified → All
Hardware: Unspecified → All
Helen, any thoughts about this?
Flags: needinfo?(hholmes)
Priority: -- → P3
It's asymmetrical because of pixel-snapping, so this is a problem that if fixed would create a fuzziness bug. Because of that I'm WONTFIX'ing it.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(hholmes)
Resolution: --- → WONTFIX
(In reply to Helen V. Holmes (:helenvholmes) (:✨)(pls ni?)(unavail.18.7-21.7) from comment #3)
> It's asymmetrical because of pixel-snapping, so this is a problem that if
> fixed would create a fuzziness bug. Because of that I'm WONTFIX'ing it.

Hi Helen, could you check expected image? Thanks.
Attached image pane-collapse.svg
Attached image pane-expand.svg
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Flags: needinfo?(hholmes)
magicp, I'm noticing the arrow corner (circled in the screenshot) is not snapped to the pixel grid which will likely cause the icon to be blurry on 1x screens.
Attached image is-this-brully.png (obsolete) —
Hi Tim, you are correct. It should be snapped to the pixel grid. My point of view is symmetry. But is this blurry? If so, should remove rounded corners.
Attached image is-this-blurry.png
Attachment #8773585 - Attachment is obsolete: true
Attached patch symmetry.patch (obsolete) — Splinter Review
Adds in the new svgs from magicp. Seems like they're pixelsnapped, but I can't tell without my display.

Tim, can you double check?

Doesn't solve the arrow issue.
Flags: needinfo?(hholmes)
Attachment #8774831 - Flags: review?(ntim.bugs)
Comment on attachment 8774831 [details] [diff] [review]
symmetry.patch

Review of attachment 8774831 [details] [diff] [review]:
-----------------------------------------------------------------

There seems to be loads of unrelated changes in this.
Attachment #8774831 - Flags: review?(ntim.bugs)
Flags: needinfo?(hholmes)
Attached patch symmetry.patchSplinter Review
Whoops, sorry about that!
Attachment #8774831 - Attachment is obsolete: true
Flags: needinfo?(hholmes)
Attachment #8775971 - Flags: review?(ntim.bugs)
Comment on attachment 8775971 [details] [diff] [review]
symmetry.patch

Review of attachment 8775971 [details] [diff] [review]:
-----------------------------------------------------------------

Based on magicp's screenshot on an 1x screen, the new icons seem alright to me.
Attachment #8775971 - Flags: review?(ntim.bugs) → review+
Keywords: checkin-needed
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/1460b360645d
Fix asymmetry for new pane toggle. r=ntim
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1460b360645d
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this Bug on Nightly 50.0a1 (2016-07-16)  on Windows 10, 64 Bit!

The bug's fix is now verified on latest  Nightly 51.0a1 (2016-08-04)

Nightly 51.0a1:
Build ID 	20160804030441
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160803]
Status: RESOLVED → VERIFIED
Comment on attachment 8775971 [details] [diff] [review]
symmetry.patch

Approval Request Comment
[Feature/regressing bug #]: bug 1260523 
[User impact if declined]: See attachment
[Describe test coverage new/current, TreeHerder]: on nightly, verified
[Risks and why]: low, SVG only change
[String/UUID change made/needed]: no
Attachment #8775971 - Flags: approval-mozilla-aurora?
Comment on attachment 8775971 [details] [diff] [review]
symmetry.patch

Image change and the fix has been verified, Aurora50+
Attachment #8775971 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.