Closed Bug 1287346 Opened 3 years ago Closed 3 years ago

[e10s] Cannot load blob:moz-extension URLs

Categories

(WebExtensions :: Untriaged, defect)

47 Branch
defect
Not set

Tracking

(e10s?)

RESOLVED DUPLICATE of bug 1279186
Tracking Status
e10s ? ---

People

(Reporter: robwu, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached file a-download-blob.zip
1. Start Firefox with e10s enabled.
2. Load the attached addon.
3. The addon opens a tab with some links and buttons.
4. Click on the links/buttons that claim to open "blob" URLs.

Expected (without e10s):
- A download dialog should be shown in all cases.

When e10s is enabled, the <a download> case also fails:
- When I click on <a download>, a load starts but never completes.
- When I press Ctrl/Cmd-click to open in a new tab, the global JS console shows:
  NS_ERROR_DOM_BAD_URI: Component returned failure code: 0x805303f4 [nsIWebNavigation.loadURIWithOptions]
  at https://dxr.mozilla.org/mozilla-central/rev/4c05938a64a7fde3ac2d7f4493aee1c5f2ad8a0a/toolkit/content/browser-child.js#332
Was broken in Nightly 50 @ 2016-07-17, working as intended since today (Nightly 2016-07-18).
Mozregression points to https://bugzilla.mozilla.org/show_bug.cgi?id=1279186 was responsible, which seems correct.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1279186
This issue has resurfaced. I cannot open blob urls (ie. blob:moz-extension://9b7041... )
I used to be able to take a screenshot with my extension https://addons.mozilla.org/en-US/firefox/addon/explain-and-send-screenshots/ and then click the Download button to open a blob url.

I'm using Firefox 48.0.2.
The url in your comment isn't a valid blob url.
However, if you think you're using blobs correctly and something isn't working, please open a new bug with detailed steps to reproduce.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.