Fennec displays a context menu on long-press, even if the 'contextmenu' is cancelled by web content

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: u549602, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox47 affected, firefox48 affected, firefox49 affected, firefox50 affected)

Details

(Reporter)

Description

3 years ago
Environment: Beta 48.0b9
Device: Samsung Galaxy S6 EDGE  (Android 6.0.1 );
Build: All;

Steps to reproduce:
1) Load http://people.mozilla.org/~kgupta/touch.html
2) Tap on the "contextmenu" checkbox. This will cause the page to call preventDefault() on contextmenu events
3) Long-press on the "Link to nowhere"
4) Reload the page and repeat step 3


Expected and actual (Step 3): No browser context menu is shown

Expected result (Step 4): No browser context menu is shown
Actual result (Step 4): Browser shows a context menu

Notes:
Tested on both Samsung Galaxy S6 edge(Android 6.0.1) and Samsung Galaxy Tab S2(Android 5.0.2) with the same result
That's because on reload the checkbox state is out of sync with the internal JS state of the page. That is, the checkbox remains checked if you reload the page while it is checked, but the code on the page is not cancelling the contextmenu events. The same behavior happens with the other check boxes. This is a bug in the test page, not in Fennec.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
Got it, Thanks
You need to log in before you can comment on or make changes to this bug.