Download is "Failed" after reconnecting to a WiFi network that was lost.

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: asimonca, Assigned: dragana)

Tracking

48 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

4.66 MB, application/x-zip-compressed
Details
(Reporter)

Description

a year ago
Issue uncovered on Windows 10 Pro Build 14390 running on MS Surface;

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Steps to reproduce:
1. Download a file.
2. Take the device outside the WiFi range until there is no more WiFi signal.
3. Take the device back and connect it to the network.

Expected results:
The download is resumed when the device is back in range.

Actual results:
The download is cancelled after connecting the device back to the network.

Note:
This is reproducible only on portable devices.

Comment 1

a year ago
I think this may be caused by the fact that we don't detect this and we don't go to offline mode.
Component: Downloads Panel → Networking
Product: Firefox → Core

Comment 2

a year ago
Or that we detect the change, but we try to connect too early, and the resume doesn't work.

Also worth checking if the link you used is actually resumable under normal conditions?
(Assignee)

Comment 3

a year ago
Can you make a Http log:
https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
Flags: needinfo?(alexandru.simonca)
(Reporter)

Comment 4

a year ago
Hello,
I have reproduced the issue again and I made sure that the link is resumable under normal conditions first. I used the same tablet (MS Surface 2) but with a newer build of Windows 10 x64 (build 14936.1000) and Firefox Beta 50.0b7 (id: 20161017130949). I have also attached an HTTP log file. Please let me know if I can be of further assistance.

Note: The log is too big to post directly to bugzilla so here is a link to it.
https://www.dropbox.com/s/qiyl5t8itg5zlh0/log.txt?dl=0
Flags: needinfo?(alexandru.simonca)
(Assignee)

Comment 5

a year ago
(In reply to Alexandru Simonca, QA (:asimonca) from comment #4)
> Hello,
> I have reproduced the issue again and I made sure that the link is resumable
> under normal conditions first. I used the same tablet (MS Surface 2) but
> with a newer build of Windows 10 x64 (build 14936.1000) and Firefox Beta
> 50.0b7 (id: 20161017130949). I have also attached an HTTP log file. Please
> let me know if I can be of further assistance.
> 
> Note: The log is too big to post directly to bugzilla so here is a link to
> it.
> https://www.dropbox.com/s/qiyl5t8itg5zlh0/log.txt?dl=0

I need a bit of help to debug this. Can you explain what you did?
There are 3 request fro 1gb.zip. Each of them did not finish.

The first one got NS_ERROR_NET_RESET

The second:
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: D/nsSocketTransport   calling PR_Read [count=28388]
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: D/nsSocketTransport   PR_Read returned [n=0]
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: V/nsHttp nsHttpConnection::OnSocketReadable 25ae8b82380 trans->ws rv=0 n=1460 socketin=80470002
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: V/nsHttp nsHttpConnection::CloseTransaction[this=25ae8b82380 trans=25adfb8fc00 reason=80470002]
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: D/nsHttp nsHttpTransaction::Close [this=25adfb8fc00 reason=0]
2016-10-18 11:52:44.808000 UTC - [Socket Thread]: D/nsHttp Partial transfer, incomplete HTTP response received: c-l underru

 "PR_Read returned [n=0]" means that a read on a socket return 0, which means that socket was closed by the remote peer.
Necko will not retry in this case.

The third one was just canceled by user.
(Reporter)

Comment 6

a year ago
In both the first cases I took the tablet outside the WiFi range to lose signal and then came back to make it reconnect to the same network automatically and resume the download, which it did. After that it just said "Failed". In the third case I canceled the download intentionally.
(Assignee)

Comment 7

a year ago
(In reply to Alexandru Simonca, QA (:asimonca) from comment #6)
> In both the first cases I took the tablet outside the WiFi range to lose
> signal and then came back to make it reconnect to the same network
> automatically and resume the download, which it did. After that it just said
> "Failed". In the third case I canceled the download intentionally.

From the log it looks like the server closed the connection. I do not see anything we did to close it.

May I ask you to try another server?
(Reporter)

Comment 8

a year ago
Sure, I'll be back with the results by EOD.
Dragana, please re-triage/re-assign as appropriate once more data is available.
Assignee: nobody → dd.mozilla
Whiteboard: [necko-active]
(Reporter)

Comment 10

a year ago
Created attachment 8803879 [details]
log.zip

Sorry for the late reply. 
I've tried reproducing the issue again using the same tablet and Nightly 52.0a1 (id: 20161024030205) and with the link "https://www.ubuntu.com/download/desktop/thank-you?version=16.04.1&architecture=amd64". I couldn't reproduce the issue anymore. I don't know if it was because the earlier download links weren't as reliable or if it was because I switched to Nightly.
I've made some more http logging but this time I wound up with four separate log.txt files. Don't know what went wrong there. I'll put a zip file with them here.
(Assignee)

Comment 11

a year ago
so you cannot reproduce the issue?

From your log, the one where a download failed, I have seen that connection was closed by the server. Therefore I assume that this is not a firefox issue and I will close it.
Flags: needinfo?(alexandru.simonca)
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 12

a year ago
 Well, the first time I found the issue was over 3 months ago so maybe something happened in the meantime that fixed the issue. I'm ok with you closing this, since I couldn't reproduce it like the first time.
Flags: needinfo?(alexandru.simonca)
You need to log in before you can comment on or make changes to this bug.