Closed Bug 1287977 Opened 5 years ago Closed 5 years ago

Modify E10sUtils.jsm to run WebExtension tab pages in the WebExtensions process

Categories

(WebExtensions :: Untriaged, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1320395

People

(Reporter: billm, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: triaged)

We do this here:
http://searchfox.org/mozilla-central/rev/65bed54efcce67cf04a890f7fe253ccdfa6befdc/browser/modules/E10SUtils.jsm#72

It forces WebExtensions page to run in the chrome process. With OOP WebExtensions, they need to run in the extension's process.
Priority: -- → P1
Whiteboard: triaged
Is it time to assign this to someone, or is the P1 designation not accurate?
Priority: P1 → P2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320395
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.