Animating an element into view, inside an overflow:hidden container causes graphical glitches

RESOLVED DUPLICATE of bug 1285174

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1285174
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 unaffected, firefox49 fix-optional, firefox50 fix-optional)

Details

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:when CSS transitions are used to animate, the element dose not appear.


+++ This bug was initially created as a clone of Bug #1275694 +++



Steps to reproduce:

1. open https://bugzilla.mozilla.org/attachment.cgi?id=8772956
2. Click TOGGLE button


Actual results:

The animating element is not visible during it's entry.  Sometimes, other visual glitches occur instead.


Expected results:

The element should smoothly transition into view.
arting position.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=204bdc8b929c88d164e165fd8f28e4c1cd002bef&tochange=7fb6f9a2d7fee76746c73fa5ba1a5c091073e199

Regressed by: Bug 1141468

Unfortunately, Bug 127569 did not fix this.
Flags: needinfo?(matt.woodrow)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1288243
status-firefox47: --- → unaffected
Tracking 49/50+ for this regression, especially since it was not addressed by the bug in Comment 0.
tracking-firefox49: ? → +
tracking-firefox50: ? → +
This is fixed by the patch in bug 1285174.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1285174

Updated

2 years ago
Component: Layout → Graphics: Layers
Migrated branch tracking over to bug 1285174.
status-firefox49: affected → fix-optional
status-firefox50: affected → fix-optional
tracking-firefox49: + → ---
tracking-firefox50: + → ---
--> Removing state about this being a regression from bug 1141468, since this is now marked as a dupe of a bug that itself is marked as a regression from bug 1141468.  (If we leave both bugs marked as "blocking" bug 1141468, then it makes it look like bug 1141468 caused more independent regressions than it actually did, when looking at it's dependency list.)
No longer blocks: 1141468
Keywords: regression
You need to log in before you can comment on or make changes to this bug.