Firefox browser window does not load during connection trouble (connected but no data transfer)

RESOLVED DUPLICATE of bug 1296836

Status

()

Toolkit
Startup and Profile System
P5
normal
RESOLVED DUPLICATE of bug 1296836
a year ago
a year ago

People

(Reporter: bull500, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
As talked in this reddit post: 
https://www.reddit.com/r/firefox/comments/4tr827/why_is_that_the_firefox_ui_never_loads_if_theres/

Problem occurs if you're connected to the ISP but there is nil data transfer.
Try starting Firefox and select the right profile.
The UI never loads. I even got a Force Close box on Fedora. 

During the first time of the reddit post i never got an unresponsive script but during the 2nd occurrence i got a message saying:
UNRESPONSIVE SCRIPT:
Script: chrome://global/content/bindings/checkbox.xml:49

I went and then launched Chrome, which it did fine and then tired loading webpages where it also failed(due to connection problem)

During the first test i fired up the stable release as well in addition to Nightly and found that it happened there as well  

Attached a video to show the full extent of the problem and hope it explains better

Updated

a year ago
Component: General → Untriaged
(Reporter)

Comment 1

a year ago
Created attachment 8773755 [details]
nostart7.mp4

Sorry for the compression 
The file was HUGE

Comment 2

a year ago
bull500: What is your home page set too?

Let's say your homepage is set to google.com. If you aren't getting a connection then the only thing that should load is 404 type of page. What exactly are you seeing?
(Reporter)

Comment 3

a year ago
(In reply to julesmyers2011 from comment #2)
> bull500: What is your home page set too?
> 
> Let's say your homepage is set to google.com. If you aren't getting a
> connection then the only thing that should load is 404 type of page. What
> exactly are you seeing?

on my stable build its set to some default distro page(Fedora)  
On Nightly my homepage is to about:home   

I hope you've seen the video   
All i get is the profile selection window and after choosing my profile i get a force close window.  
Sometime unresponsive script in addition.  
I never get to see the Firefox Browser. It remains stuck on the profile chooser.
I cannot reproduce with Nightly and Fedora 23 32-bit. I will try to get a Virtual build for 64-bit.
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Component owner: Please note I could not reproduce with Fedora 24 64-bit 
50.0a1
20160726080520
Mozilla/5.0 (X11; Linux x86_64; rv:50)
I should also clarify: I can interfere with the Network and produce the UNRESPONSIVE SCRIPT:
Script: chrome://global/content/bindings/checkbox.xml:49 - However I successfully recover and the about:about page successfully displays.
(Reporter)

Comment 7

a year ago
Found a better STR for this issue  

You'll need two devices a desktop/laptop with Firefox and an android phone.  

Start Firefox and leave it at the Profile Selection window. DONOT select the profile and start the browser.  

Now on the mobile device direct to the default modem page of your WIFI Modem and reset the modem via the page(most likely under maintenance options of the modem webpage)  

Once the disconnection happens select your profile on Profile Selection window and start Firefox.  

Notice the delay for the Firefox windows to showup until the connection to the ISP is established

Comment 8

a year ago
bull500, do you have any addons installed? I cannot reproduce, nor can our QA. Next steps on this are pretty technical: getting a JS and C++ stack at the time of the hang; but that cannot really be done without a debugger and a self-build with symbols.

Since you're the only person who has reported this that I know of, I'm not sure I can dedicate Mozilla engineering time to figuring it out.
Flags: needinfo?(bullionareboy)
Priority: -- → P5
(Reporter)

Comment 9

a year ago
Created attachment 8784604 [details]
Screenshot from 2016-08-25 04-37-51.png

(In reply to Benjamin Smedberg [:bsmedberg] from comment #8)
> bull500, do you have any addons installed? I cannot reproduce, nor can our
> QA. Next steps on this are pretty technical: getting a JS and C++ stack at
> the time of the hang; but that cannot really be done without a debugger and
> a self-build with symbols.
> 
> Since you're the only person who has reported this that I know of, I'm not
> sure I can dedicate Mozilla engineering time to figuring it out.

it still happens on Fedora Linux on a fresh profile(no addons) Nightly 51 latest build 
its this delay to launch firefox browser window while the Isp is connecting after modem reboot or if theres not data transfer between me and ISP.   

Attaching the image for the slow script on start up if it helps     
The video has already been posted
Flags: needinfo?(bullionareboy)

Comment 10

a year ago
Somebody else also reported this, and we have a stacktrace in the other bug report. So I'm going to mark this one a duplicate. Thank you for reporting!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1296836
You need to log in before you can comment on or make changes to this bug.