Google Maps printouts do not print all pages/directions. First and last page blank.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
3 years ago
2 months ago

People

(Reporter: jtgoen, Assigned: dholbert)

Tracking

(Depends on 1 bug, Blocks 1 bug, {productwanted})

Firefox 49
x86_64
Windows 10
Dependency tree / graph

Firefox Tracking Flags

(platform-rel +, firefox47 affected, firefox48 affected, firefox49 affected, firefox-esr45 affected, firefox50 affected)

Details

(Whiteboard: [platform-rel-Google][platform-rel-GoogleMaps], URL)

Attachments

(2 attachments)

865.57 KB, application/pdf
Details
616.74 KB, application/x-zip-compressed
Details
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160722004032

Steps to reproduce:

1. Plot route in Maps from Albuquerque, NM to Telluride, CO
2. Choose the route via US 550 North.
2. Attempt to print directions.
3. View directions in PDF.


Actual results:

Directions page was malformed, with first and third page being nearly blank, and the page with information on it was cropped to be unusable. See attached PDF.


Expected results:

Document should have two pages of directions with no blank pages.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Updated

3 years ago
Attachment #8773759 - Attachment description: alb-to-telluride.pdf → abq-to-telluride.pdf
Attachment #8773759 - Attachment filename: alb-to-telluride.pdf → abq-to-telluride.pdf

Comment 2

3 years ago
seems Bug 534182
Status: UNCONFIRMED → NEW
Component: Untriaged → Printing: Output
Ever confirmed: true
Product: Firefox → Core

Comment 3

3 years ago
I am having this same problem with firefox 47.0.1

Printing any google map directions results in first and last page blank.  This only occurs in Firefox.
Tried IE11 and google map directions print properly

Updated

3 years ago
Duplicate of this bug: 1294424
(Assignee)

Comment 5

3 years ago
css-classname-changed
This is a version of bug 939897 (as noted in bug 939897 comment 7).  Google Maps printed directions are contained within a wrapper-element (with class="widget-pane-section-listbox-root") that is a column-oriented flex container:
>.widget-pane-section-listbox-root {
>	display:flex;
>	flex-direction:column;
>	height:100%
>}
Depends on: 939897
(Assignee)

Updated

3 years ago
Summary: Developer Edition 49.0a2 (2016-07-22) Google Maps printouts do not print all pages/directions. First and last page blank. → Google Maps printouts do not print all pages/directions. First and last page blank.
platform-rel: --- → ?
Whiteboard: [platform-rel-Google][platform-rel-GoogleMaps]
Blocks: 1302489
platform-rel: ? → +
Rank: 18
Assigning per dholbert, this is a flexbox fragmentation bug.
Assignee: nobody → dholbert

Updated

2 years ago
Duplicate of this bug: 1318527
(Assignee)

Comment 8

2 years ago
We should absolutely fix this (via bug 939897), but it's complex to fix correctly/comprehensively, so in the interests of giving our users a better experience in the very-near term, we should reach out to Google Maps to see if they can avoid triggering this bug for our mutual users.

(As it happens, the code that they added which triggers this bug seems to be completely unnecessary, as far as I can tell, and can be removed without any side effects [besides this bug going away]. See https://github.com/webcompat/web-bugs/issues/3727 for more details -- I filed that to cover webcompat outreach.)
(Assignee)

Comment 9

2 years ago
(Note that the classname for the problematic styles here -- quoted in comment 5 -- has changed slightly. It's no longer "widget-pane-section-listbox-root" -- now the relevant styles are:
> .section-listbox-root{display:flex;flex-direction:column;height:100%}
This seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 11

2 years ago
Tested with Firefox 50.1.0 and the issue appears to have been fixed
(Assignee)

Comment 12

2 years ago
Yeah, Google seems to have added the following CSS rule, which overrides the CSS mentioned in comment 9:
> .print-mode .section-listbox-root {
> 	display:block;
> 	height:auto
> }

That avoids the problem here. Hooray!
(Assignee)

Comment 13

2 years ago
Reclassifiying as Tech Evangelism, since this was fixed in Google Maps' code, rather than in Firefox's code.

(There is a Firefox fix that still needs to happen to avoid this problem generally, but that's tracked in bug 939897.)
Status: RESOLVED → VERIFIED
Component: Printing: Output → Desktop
Product: Core → Tech Evangelism
Version: 49 Branch → Firefox 49
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.