Closed Bug 1288913 Opened 4 years ago Closed 4 years ago

Allows a single ticket to have both status resolved and resolution "won't fix" (WONTFIX)

Categories

(bugzilla.mozilla.org :: Bug Creation/Editing, defect)

Production
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: chealer, Unassigned)

Details

BMO allows a ticket which has its Resolution field set to WONTFIX to also have its Status field set to RESOLVED. While this is not technically incorrect (a resolved issue obviously will not be solved), the idea behind WONTFIX is of course to identify unsolved issues which (allegedly) will never be solved.

An example can currently be seen in ticket #1285748: https://bugzilla.mozilla.org/show_bug.cgi?id=1285748

Either one of these options should be disabled when the other is selected, or there should be a validation when submitting. Since issues marked as not going to be solved are frequently solved, it is necessary that the solution allows a WONTFIX ticket to be marked as resolved (perhaps asking the user which resolution was taken).
The bug is RESOLVED as WONTFIX (won't be fixed), I see no issue here with this naming.
indeed; this is working as intended.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #1)
> The bug is RESOLVED as WONTFIX (won't be fixed), I see no issue here with
> this naming.

I know what "WONTFIX" means; what is "RESOLVED as WONTFIX" supposed to mean?
Byron, what do you mean? Are you just saying you do not consider it a bug that a resolved issue can have its Resolution field set to WONTFIX?
They are two separate fields.  As has been explained in bug 1285748, the status of "RESOLVED" means that the owners of the product or component have firmly decided on a course of action.  Other statuses indicate other states of a bug, e.g., "UNCONFIRMED" means that no one who works on the particular component has yet confirmed that the bug exists or not.

While there are many words and phrases that could be used as status and resolution values, we have settled on the current set as being sufficient to reflect the main workflows here at Mozilla, and as such they have been ingrained into many processes and tools.  We will not be changing them without a very good reason and general agreement from the engineering groups.

To specifically answer your question, if a bug has moved to the state of RESOLVED, then the resolution field is used to briefly explain the chosen course of action.  In this case, it is WONTFIX, which means that we will not be fixing it, because, as you say, we do not view this as a bug.

To put it another way, we have firmly decided that we do not view this report as a bug, and hence we will not be fixing it.
(In reply to Filipus Klutiero from comment #6)
> The person who provided that "explanation" in ticket #1285748 has been
> challenged in Comment #13, and has failed to answer so far. Since that
> theory also conflicts with the documentation, I consider it wrong.

that question has been answered multiple times.  i've answered it again for you below.

> Ticket #1285748 is neither a bug nor a bug report, but a request for
> enhancement. Note that even bug reports reporting behaviors which are not
> considered as bugs should not be set to WONTFIX (they should be set to
> INVALID).

let me make this clear:  we will NOT be making the change you suggest here, or in bug 1285748.
there is nothing you can say that will alter that.

pushing on this issue further may result in your account being disabled.
(In reply to Byron Jones ‹:glob› from comment #7)
> (In reply to Filipus Klutiero from comment #6)
> > The person who provided that "explanation" in ticket #1285748 has been
> > challenged in Comment #13, and has failed to answer so far. Since that
> > theory also conflicts with the documentation, I consider it wrong.
> 
> that question has been answered multiple times.  i've answered it again for
> you below.

That question was asked in Comment #13, which is the last comment at this time. If you have access to any answer to that, reposting it would be more useful than pretending it has already been answered multiple times.
 
> > Ticket #1285748 is neither a bug nor a bug report, but a request for
> > enhancement. Note that even bug reports reporting behaviors which are not
> > considered as bugs should not be set to WONTFIX (they should be set to
> > INVALID).
> 
> let me make this clear:  we will NOT be making the change you suggest here,
> or in bug 1285748.
> there is nothing you can say that will alter that.

The righter you will be, the more important this issue will be. This ticket is not asking to solve issues marked as WONTFIX; it is asking to ensure these are not presented as resolved. The longer issues which are only tracked in a ticket marked as WONTFIX and RESOLVED persist, the more likely we are to get duplicates.

> pushing on this issue further may result in your account being disabled.

Let us stick to topic; the issue reported in ticket #1285748 should be discussed in ticket #1285748. As for this one, what you were asked was an explanation for your statement that "this is working as intended".
(In reply to Filipus Klutiero from comment #8)
> > pushing on this issue further may result in your account being disabled.
> 
> Let us stick to topic; the issue reported in ticket #1285748 should be
> discussed in ticket #1285748. As for this one, what you were asked was an
> explanation for your statement that "this is working as intended".

a very clear explanation was provided in comment 5.

unfortunately your activities here have left me with little choice but to disable your account.  it's great that you're passionate about some things, but you have to pick your battles and stand down when given clear answers and resolutions.
You need to log in before you can comment on or make changes to this bug.