remove balrog api-9 rules

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
3 months ago

People

(Reporter: jlund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
after release 48.0 we are not going to ship api-9 based releases anymore. Since updates will be frozen, I suppose we can delete any api-9 rule that would typically serve updates.
(Reporter)

Comment 1

2 years ago
actually, I just remembered we don't ship fennec or even store release blobs as back up via balrog and instead rely solely on Google Play Store.

so we can probably action this bug anytime. I'll have a look next week.
Does this apply to single locale builds as well, which aren't shipped through the Play store? If so, removing the API-9 rule completely will cause those requests to end up matching a rule which would presumably serve them an incompatible build. Typically when we desupport a platform or arch we need to keep a rule around in perpetuity that points at a DesupportBlob. You can see this in action with rule id 341, which handles GTK deprecation on the release channel.

Let me know if you want to chat more about this.
(Reporter)

Comment 3

2 years ago
ah, good point. long live the legacy!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Assignee)

Updated

3 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.