Closed Bug 1288955 Opened 6 years ago Closed 6 years ago

[10.12] stuttering audio playback since upgrade to macOS Sierra

Categories

(Core :: Audio/Video: Playback, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox50 --- affected

People

(Reporter: soeren.hentzschel, Unassigned)

References

Details

Firefox is "unusable" for playback of audio or video since macOS Sierra Public Beta 1 (and it's still an issue in Public Beta 2). It's difficult to describe for me, but I'll try.

Firefox is able to play audio and video, it works in theory. But in practice every few seconds the sound stops for a few milliseconds. it's always a very short stop but it's very noticeable, that's why I described it with the word "unusable", because it's really no fun to use Firefox for watching videos or listening music with this issue.

Sometimes it happens after five seconds, sometimes after 30 seconds but it happens again and again. It happens on YouTube, on Soundcloud and on other platforms so it's not a website specific issue. It happens with Firefox 47.0.1 Stable and Firefox Nightly 50 (with a new profile), and the issue was not present in OS X 10.11, neither with the current stable release nor with Firefox Nightly at the time before the upgrade. The issue is not present in Chrome and Safari.
This is most likely due to bug 1287156.
Depends on: 1287156
Sören, do you see this on non-Nightly versions of Firefox?

If this is really caused by bug 1287156, then it's Nightly-only, because we only use --enable-replace-malloc on Nightly.
Flags: needinfo?(cadeyrn)
I can't reproduce with Firefox 48.0 Stable, but with the current Firefox Nightly. That's strange because I am sure I was able to reproduce with Firefox 47.0.1 Stable two weeks ago, but either I was wrong or things changed between Firefox 47 and 48 or with the latest Sierra Beta.

tl;dr: only reproducible with Firefox Nightly.
Flags: needinfo?(cadeyrn)
(In reply to Markus Stange [:mstange] from comment #1)
> This is most likely due to bug 1287156.

Bug 1287156 is RESOLVED WORKSFORME since the latest Sierra beta and I can confirm that this issue is also fixed with the latest beta.
Great. I can report the same.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.