Closed Bug 1289152 Opened 5 years ago Closed 5 years ago

Colorpicker stops working after using the new eyedropper

Categories

(DevTools :: Inspector: Rules, defect)

defect
Not set
normal

Tracking

(firefox50 fixed)

RESOLVED FIXED
Firefox 50
Tracking Status
firefox50 --- fixed

People

(Reporter: jdescottes, Unassigned)

References

Details

Attachments

(2 files)

Regression from 1262439.

STRs:

- open inspector > ruleview
- create a property color: red
- open the color picker 
- click on the eyedropper icon
- pick a color on the page
- (color picker is automatically closed, picked color is set as property value)
- open the color picker
- try to update the color using the gradient background

ER: Colorpicker widget should still work
AR: Colorpicker widget is no longer working
Blocks: 1262439
The eyedropper gets hidden when canceled and when selecting a color.
The Tooltip should listen to both events to update its internal state flags.

Review commit: https://reviewboard.mozilla.org/r/66908/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/66908/
Attachment #8774453 - Flags: review?(zer0)
Comment on attachment 8774453 [details]
Bug 1289152 - switch eyedropperOpen flag in Tooltip when picking color;

https://reviewboard.mozilla.org/r/66908/#review64510

::: devtools/client/shared/widgets/Tooltip.js:868
(Diff revision 1)
>      this.hide();
>  
>      this.tooltip.emit("eyedropper-opened");
>    },
>  
> +  _onEyeDropperDone: function () {

We usually uses the prefixed `on` for function's name that are actually listener, bound to specific events; in that case it seems there is no direct correlation, so it's a bit misleading. I would probably call the function just `this._eyeDropperDone` – or anything else doesn't include `on` as prefix.

(I'm not going to block this bug just for the naming convention, since you're also in PTO, I writing this done just as reminder, maybe we could fix it in one of the eye dropper follow up bug)
Attachment #8774453 - Flags: review?(zer0) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/80206c183389
Switch eyedropperOpen flag in Tooltip when picking color. r=zer0
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/80206c183389
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.