Closed Bug 1289292 Opened 3 years ago Closed 3 years ago

[Presentation WebAPI] terminate PresentationConnection locally while fail to establish control channel

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
blocking-b2g 2.6+
Tracking Status
b2g-v2.6 --- fixed
firefox50 --- fixed

People

(Reporter: schien, Assigned: schien)

References

Details

Attachments

(2 files, 1 obsolete file)

In current m-c, PresentationSessionInfo::Close didn't handle failure during control channel establishment.

https://hg.mozilla.org/mozilla-central/file/tip/dom/presentation/PresentationSessionInfo.cpp#l303
Attached patch local-terminate-while-fail.patch (obsolete) — Splinter Review
Make sure |Shutdown| is invoked when fail to establish control channel or fail to send terminate command.
Attachment #8774981 - Flags: review?(bugs)
Comment on attachment 8774981 [details] [diff] [review]
local-terminate-while-fail.patch

>+function testConnectionAvailable() {
>+  return new Promise(function(aResolve, aReject) {
>+    info('Receiver: --- testConnectionAvailable ---');
>+    ok(navigator.presentation, 'Receiver: navigator.presentation should be available.');
>+    ok(navigator.presentation.receiver, 'Receiver: navigator.presentation.receiver should be available.');
>+
>+    navigator.presentation.receiver.connectionList
>+    .then((aList) => {
>+      is(aList.connections.length, 1, 'Should get one conncetion.');
connection
Attachment #8774981 - Flags: review?(bugs) → review+
update according to review comment, carry r+.
Attachment #8774981 - Attachment is obsolete: true
Attachment #8775403 - Flags: review+
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1276378
User impact if declined: cannot initiate page terminate on receiver side
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: n/a
Attachment #8775407 - Flags: approval-mozilla-b2g48?
blocking-b2g: 2.6? → 2.6+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4730019ab44c
Shutdown session info while fail to establish control channel. r=smaug
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4730019ab44c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Comment on attachment 8775407 [details] [review]
pull request for tv 2.6

Approve for TV2.6
Attachment #8775407 - Flags: approval-mozilla-b2g48? → approval-mozilla-b2g48+
Comment on attachment 8775407 [details] [review]
pull request for tv 2.6

ni @xeonchen for uplift.
Flags: needinfo?(xeonchen)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.