Georgian (ka) Developer Edition builds are not available for download on mozilla.org

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: flod, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
https://www.mozilla.org/ka/firefox/channel/#developer

As you can see the download button suggests to download the en-US build, OS X in my case: https://download.mozilla.org/?product=firefox-aurora-latest-ssl&os=osx&lang=en-US

But Georgian builds are available for the aurora/devedition channel, e.g. https://download.mozilla.org/?product=firefox-aurora-latest-ssl&os=osx&lang=ka

I assume the problem is in product-details, for example compare 'ka' with 'ltg' (they're in the same situation, only Aurora builds)

ka: http://viewvc.svn.mozilla.org/vc/libs/product-details/firefoxDetails.class.php?revision=150449&view=markup#l488

ltg: http://viewvc.svn.mozilla.org/vc/libs/product-details/firefoxDetails.class.php?revision=150449&view=markup#l545

Not completely sure if SVN is still the source of truth for product-details these days.
(Reporter)

Comment 1

2 years ago
This looks fixed to me locally, I assume we still need to switch to use the new product-details?
https://github.com/mozilla/bedrock/pull/4267/
Flags: needinfo?(jmize)
(In reply to Francesco Lodolo [:flod] from comment #1)
> This looks fixed to me locally, I assume we still need to switch to use the
> new product-details?
> https://github.com/mozilla/bedrock/pull/4267/

Yes, as discussed in IRC yesterday that PR switched the default, but we had explicitly set the environment variable to the product-details in svn due to some issues that arose the last time we tried to switch. I removed that environment variable yesterday and forced an update of the product details by running "./manage.py update_product_details -f" in each of the production environments, and verified that the developer edition download button on https://www.mozilla.org/ka/firefox/channel/#developer now ends with "&lang=ka" as expected.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jmize)
Resolution: --- → FIXED
(Reporter)

Comment 3

2 years ago
Thanks Josh! Glad to see the new product-details in place.
You need to log in before you can comment on or make changes to this bug.