when building the summary file for a empty local folder, it "spins"

VERIFIED DUPLICATE of bug 13043

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 13043
20 years ago
3 years ago

People

(Reporter: sspitzer, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

it "spins" means the barber poll spins and I see the status message "Building
summary file for <foldername>..."

to reproduce, create an empty file on disk under your pop mail local mail
folder.

start up 5.0.

select that file in the folder pane.

in the debugger I'm seeing the nsMsgMailboxParser::OnStartRequest() but never
the nsMsgMailboxParser::OnStopRequest().
Status: NEW → ASSIGNED
Target Milestone: M11
accepting
OS: Linux → All
Hardware: PC → All
jfd mentioned this to putterman yesterday - jfd was seeing this on the Mac so
I'll cc him as a fyi.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I just realized this is surely a dup of #13043 where necko is hanging when
trying to load files of size 0 bytes. Actually hanging is the wrong word...we're
running into a deadlock situation.

This isn't actually a mailnews bug at all. If you load a file url with 0 bytes
you'll see the same problem.

*** This bug has been marked as a duplicate of 13043 ***
Status: RESOLVED → VERIFIED
Marking verified as duplicate
Duplicate bug has been marked fixed, but not yet verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.