JavaScript is not activated

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: pierre-olivier, Unassigned)

Tracking

47 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/601.7.7 (KHTML, like Gecko) Version/9.1.2 Safari/601.7.7

Steps to reproduce:

Update to 47.0.1


Actual results:

All websites working with javascript don't work properly: GitHub for example (unable to modify settings), bank account (in order to log in), etc. I try to start Firefox without modules: the results are the same.


Expected results:

Working websites. These websites are accessible on Safari.
(Reporter)

Updated

2 years ago
Severity: normal → blocker
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Is the issue reproducible with safe mode [1], and clean profile [2]?

Also, can you provide the actual URL the issue happens?

[1] https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
[2] https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(pierre-olivier)
(Reporter)

Comment 2

2 years ago
The issue is reproducible with safe mode. I haven't test the clean profile. 

You can try this address: https://www.youtube.com/watch?v=jqdOkXQngw8 => no video appears
Flags: needinfo?(pierre-olivier)
The video appears for me.
If the issue also happens with safe mode, it could be caused by your configuration.

Can you provide the troubleshooting information, by following?
  1. open about:support
  2. click "Copy raw data to clipboard"
  3. save the copied text as a file
  4. attach the file to this page

Updated

2 years ago
Flags: needinfo?(pierre-olivier)
(Reporter)

Comment 4

2 years ago
Created attachment 8775547 [details]
Copy of the raw data from about:support
>     "javascript.enabled": false,
this means you disabled JavaScript.

try resetting the pref by following:
  1. open about:config
  2. search javascript.enabled
  3. right click (or 2nd button click) on the "javascript.enabled", and choose "Reset" menu item
Severity: blocker → normal
(Reporter)

Comment 6

2 years ago
It works. Many thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Flags: needinfo?(pierre-olivier)
You need to log in before you can comment on or make changes to this bug.