nsIMsgCompDeliverMode disappeared from compose window in 2.41a1?

RESOLVED FIXED in seamonkey2.52

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jik, Assigned: frg)

Tracking

({regression})

SeaMonkey 2.41 Branch
seamonkey2.52
regression

SeaMonkey Tracking Flags

(seamonkey2.48 affected, seamonkey2.49esr fixed, seamonkey2.50 fixed, seamonkey2.51 fixed, seamonkey2.52 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
My add-on uses the global variable nsIMsgCompDeliverMode in the message composition window.

This variable is no longer defined when my JavaScript code that is pulled in by an XUL overlay for this window tries to use it.

I bisected nightly builds, and I found that the variable is defined in the nightly comm-central-trunk x86_64 Linux build on 10/7/2015, and undefined in the build on the next night, 10/8/2015.

I have looked at the commit messages for the comm-central changes between those two builds, as well as at the diff, and I can't see anything that would explain this change in behavior.

Current Thunderbird trunk still has the variable defined.
(Assignee)

Comment 1

2 years ago
Probably related to Bug 1209777.

It's a const in SeaMonkey and a var in TB.

I can put up a patch. Could you tell ne with which addon I can test it.
status-seamonkey2.48: --- → affected
status-seamonkey2.49esr: --- → affected
status-seamonkey2.50: --- → affected
status-seamonkey2.51: --- → affected
status-seamonkey2.52: --- → affected
Flags: needinfo?(jik)
Version: Trunk → SeaMonkey 2.41 Branch
(Reporter)

Comment 2

2 years ago
Version 6.0.2 of Send Later (https://addons.mozilla.org/en-US/thunderbird/addon/send-later-3/versions/6.0.2) has the problem. There's a workaround in newer versions, so if you want to reproduce the problem and confirm that it's fixed, you will need to use 6.0.2.

Unfortunately, you won't see an error in the error console when the problem manifests (I've found that Firefox, Thunderbird, SeaMonkey, etc. are incredibly unpredictable about when JavaScript errors in add-on code get logged and when they don't), but you will know the problem is happening because when you compose a message and type Ctrl-Shift-Enter, the message will get put into your Outbox, rather than the Send Later dialog popping up.

Thanks.
Flags: needinfo?(jik)
(Assignee)

Comment 3

2 years ago
Created attachment 8863197 [details] [diff] [review]
1290187-MsgComposeCommands-Const.patch

[Approval Request Comment]
Regression caused by (bug #): 589199 
User impact if declined: Addon copy-sent-to-current and probably others broken.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): very very low.
String changes made by this patch: none

comm-release implies approval for comm-esr52 too.

I took only the patch for MsgComposeCommands.js from Bug 1209777. 

Neil indicated in Bug 1209777 Comment 29 that SeaMonkey doesn't need the patch. That seems only to be true for the base product but not for add-ons. At least one other add-on (copy-sent-to-current) broke too. Tested this one with the patch and works fine now.

I reran

> find suite/ -type f -iname *.js* -exec sed -i -E 's/^(const|let) /var /g' {} \;

and looked at the changed Files. I think we shouldn't change anything else based on the output. The other changes are mostly real constants only used in the file they are declared in and test code. As long as no other breakages are reported I wouldn't want to change them.

If ewong is ok with this I would like to take it to 2.48 too.
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8863197 - Flags: review?(iann_bugzilla)
Attachment #8863197 - Flags: feedback?(ewong)
Attachment #8863197 - Flags: approval-comm-release?
Attachment #8863197 - Flags: approval-comm-beta?

Comment 4

2 years ago
Comment on attachment 8863197 [details] [diff] [review]
1290187-MsgComposeCommands-Const.patch

r/a=me
Attachment #8863197 - Flags: review?(iann_bugzilla)
Attachment #8863197 - Flags: review+
Attachment #8863197 - Flags: approval-comm-release?
Attachment #8863197 - Flags: approval-comm-release+
Attachment #8863197 - Flags: approval-comm-beta?
Attachment #8863197 - Flags: approval-comm-beta+
(Assignee)

Comment 5

2 years ago
https://hg.mozilla.org/comm-central/rev/5de9486031f54cadc9d0a0874f0ec11dfd3e5fc6
https://hg.mozilla.org/releases/comm-beta/rev/1271df77a4170cd10be52f73488d5176da88343e
https://hg.mozilla.org/releases/comm-release/rev/5f80d510273647f40adc2981b0a8bcf549e3b30a
https://hg.mozilla.org/releases/comm-esr52/rev/05d34164510b2d6c0914913c353b8330fcec49c9

Didn't push it to 2.48 yet.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.49esr: affected → fixed
status-seamonkey2.50: affected → fixed
status-seamonkey2.51: affected → fixed
status-seamonkey2.52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.52
I'm going to suggest we not add this to 2.48 since we didn't even include it
during the beta stage.
Attachment #8863197 - Flags: feedback?(ewong)
You need to log in before you can comment on or make changes to this bug.