Is Focus blocking embedded Twitter content on Facebook?

RESOLVED WONTFIX

Status

Focus-iOS
General
RESOLVED WONTFIX
a year ago
4 months ago

People

(Reporter: rfeeley, Unassigned)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8776145 [details]
2016-07-29 06.54.22.png

In Safari on iOS I notice that embedded Twitter images are not appearing on Facebook. Could it be Focus?
I can confirm it's Focus related, but the strange thing is that it doesn't block all Twitter embedded images. For me it blocked roughly half.
Javaun, is there a good component or other place to put these Disconnect blocklist bugs?
Flags: needinfo?(jmoradi)
I'm adding this to the meta bug 1101005.
Blocks: 1101005
Flags: needinfo?(jmoradi)
I put it blocking the Tracking Protection bug, which uses the same list. 

To update the list, we'd need to re-release Focus, since it doesn't use a service. But the list provider (Disconnect) would need to remove Twitter according to Policy reasons. 

Focus also doesn't have user-driven whitelisting to disable Focus for a site.
This is the offending entry: https://github.com/mozilla-services/shavar-prod-lists/blob/12e0ffbfb3bb02a038002cf638a0f2a0f5de03d6/disconnect-blacklist.json#L65
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.