Expose iterator stuff on NodeList and DOMTokenList

RESOLVED FIXED in Firefox 50

Status

()

defect
RESOLVED FIXED
3 years ago
3 months ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

({dev-doc-complete})

Trunk
mozilla50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

The DOM spec has these.  Chrome is shipping at least on NodeList (as in, it's in Chrome release), which suggests it's web-compatible.
There were two issues:

1) The keys/entries/values/forEach properties were being added no matater what
the value of the 'unforgeable' boolean was.  So we ended up spitting out
unforgeable versions of those, and this confused some Xray cases.

2) The number of args listed for forEach was wrong, which hit assertions in the
JS engine because the same self-hosted function was being instantiated with
different numbers of args from different places.
Attachment #8776223 - Flags: review?(kyle)
There were two issues:

1) The keys/entries/values/forEach properties were being added no matater what
the value of the 'unforgeable' boolean was.  So we ended up spitting out
unforgeable versions of those, and this confused some Xray cases.

2) The number of args listed for forEach was wrong, which hit assertions in the
JS engine because the same self-hosted function was being instantiated with
different numbers of args from different places.
Attachment #8776228 - Flags: review?(kyle)
Attachment #8776223 - Attachment is obsolete: true
Attachment #8776223 - Flags: review?(kyle)
Attachment #8776228 - Flags: review?(kyle) → review+
Attachment #8776229 - Flags: review?(kyle) → review+
Duplicate of this bug: 1215925

Comment 5

3 years ago
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b62785dbfe3
Fix some bugs in the way single-type (value) iterators are hooked up in the Web IDL bindings.  r=qdot
https://hg.mozilla.org/integration/mozilla-inbound/rev/49efb446f5b0
Expose iterator stuff on NodeList and DOMStringList.  r=qdot

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6b62785dbfe3
https://hg.mozilla.org/mozilla-central/rev/49efb446f5b0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Note for documentation team: see specifications: https://dom.spec.whatwg.org/#interface-nodelist and https://dom.spec.whatwg.org/#interface-domtokenlist; also, this is already shipping in Chrome stable. No information on Safari or Edge implementation plans at this time.

Updated

9 months ago
Depends on: 1496118
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.