Changes on Keyword search or existence of it's originating bookmark do nothing

RESOLVED DUPLICATE of bug 1150678

Status

()

RESOLVED DUPLICATE of bug 1150678
2 years ago
2 years ago

People

(Reporter: iraola887, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr45 affected, firefox50 affected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160601155443

Steps to reproduce:

Define a keyword search by rightclicking a searchbox example: "g" for  google.com/search?q=%s

Try modifiying the address Example edit either the keyword "g" to "go" or "google.com/search?q=%s" to "google.co.jp/search?q=%s" or delete the originating bookmark.

Result? Nothing changed. Example: Firefox still uses "g" to search even if the bookmark doesn't exist anymore, "go" won't work and the address for the search it will use will be google.com/search?q=%s not google.co.jp/search?q=%s


Actual results:

If you define a keyword for a search and then try to modify the address or keyword the original address/keyword will be used when you do the keyword search and if you delete the related bookmark the keyword will still exist.




Expected results:

Changes to be reflected on behavior of the browser.
I can reproduce the issue partially, with the following steps:
  1. run Firefox ESR45 (or Nightly)
  2. open https://www.google.com/
     (at this point it's redirected to https://www.google.co.jp for me instead, so I use Yahoo for the another URL to make it clearer)
  3. right click the input form, and click "Add keyword for this Search..."
  4. insert "g" in "Keyword:"
  5. click "Save"
  6. open Bookmark Sidebar
  7. right click "Search Google" (added by step 5), and click "Properties" menu item
  8. change "Location:" to "https://search.yahoo.com/yhs/search?p=%s"
  9. click "Save"
  10. enter "g hello" in location bar and hit enter
  11. right click "Search Google", and click "Properties" menu item
  12. change "Keyword:" to "go"
  13. click "Save"
  14. enter "g hello" in location bar and hit enter
  15. enter "go hello" in location bar and hit enter
  16. right click "Search Google" (added by step 5), and click "Delete" menu item
  17. enter "g hello" in location bar and hit enter
  18. enter "go hello" in location bar and hit enter

actual behavior:

  step 10: open search result for "hello" with google
  step 11: "Keyword:" is empty
  step 14: open search result for "hello" with google
  step 15: open search result for "hello" with yahoo
  step 17: open search result for "hello" with google
  step 18: open search result for "go hello" with default search engine


expected behavior:

  step 10: open search result for "hello" with yahoo
  step 11: "Keyword:" is "g"
  step 11: open search result for "g hello" with default search engine
  step 12: open search result for "hello" with yahoo
  step 14: open search result for "g hello" with default search engine
  step 15: open search result for "go hello" with default search engine
Status: UNCONFIRMED → NEW
QA Whiteboard: [bugday-20160801]
status-firefox50: --- → affected
status-firefox-esr45: --- → affected
Component: Untriaged → Places
Ever confirmed: true
Product: Firefox → Toolkit

Comment 2

2 years ago
Seems duplication of Bug 1285142

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.