Next page link opens URLs with blank search string parameter

RESOLVED FIXED

Status

Air Mozilla
Other
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Ertugrul Keremoglu, Unassigned)

Tracking

Details

(Whiteboard: python django)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

I typed `tag: rust` into the search box and clicked `search` button.
There were first ten posts with the text `40 events found.` So there should be three pages more. I clicked `Next page` link. There was no result.


Actual results:

When I clicked to `Next page` link it tried to open the next page without using search string (GET parameter q). So, the q parameter gets blank.

Example:
https://air.mozilla.org/search/?q=&page=2


Expected results:

The `Next page` link should contain q parameter as equal to search string.

Expected URL sample:
https://air.mozilla.org/search/?q=tag%3A+rust&page2
Thank you! Great bug report.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

a year ago
(In reply to Peter Bengtsson [:peterbe] from comment #1)
> Thank you! Great bug report.

You're welcome. : )
(Reporter)

Updated

a year ago
Whiteboard: python django
The error you mentioned in email from the docker-compose happens because the `pip` in the docker is too old. It needs an upgrade. At some point you need to execute: `python bin/pipstrap.py` (before the `pip install ...`).
See if that helps.
See https://bugzilla.mozilla.org/show_bug.cgi?id=1292937 for the topic of getting docker working.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.