Closed Bug 1290770 Opened 4 years ago Closed 11 months ago

Crash in mozilla::WebGLTexture::CopyTexImage2D, with no log of failed call args.

Categories

(Core :: Canvas: WebGL, defect, P3, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: njn, Assigned: jgilbert)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-feeabbf6-9003-4cc7-8efb-e469a2160527.
=============================================================

I only see 5 occurrences of this crash, 4 on Linux, 1 on Windows, but it's a nice understandable MOZ_RELEASE_ASSERT failure so seems worth filing.

jgilbert, any ideas?
Whiteboard: [gfx-noted]
This is probably bug 1290634.
Maybe it's solved by bug 1290634. But I think it's worth to have attachment 8776490 [details] [diff] [review]. Then we can check the gl parameters if there has another error code.
Assignee: nobody → hshih
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1290634
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Crash in mozilla::WebGLTexture::CopyTexImage2D → Crash in mozilla::WebGLTexture::CopyTexImage2D, with no log of failed call args.
Attachment #8776490 - Flags: review?(jgilbert) → review+
Assignee: bignose1007+bugzilla → jgilbert
Component: Graphics → Canvas: WebGL
Attachment #8776490 - Attachment is obsolete: true
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4044c8713862
Log bad tex upload calls and errors. r=lsalzman
Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.