Closed Bug 1290822 Opened 4 years ago Closed 3 years ago

thunderbird freezes (100% cpu) when adding a certain caldav calendar

Categories

(Calendar :: Provider: CalDAV, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 875739

People

(Reporter: f.roussin, Unassigned)

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160607205127

Steps to reproduce:

I added a caldav calendar (which is fully readable from other caldav clients like evolution) on thunderbird (tested on linux/windows, v38 -> 45).


Actual results:

Thunderbird first display several entries from this calendar,, then hangs (window freezes, while it takes 100% CPU ressources).
Last lines of console output are : 
------------------------------
CalDAV: Still need to fetch 95 elements.
CalDAV: send([...]cgpitem1.ics</D:href></C:calendar-multiget>
------------------------------




Expected results:

Thunderbird should display the whole .alendar (not the a few entries) as it does for other calendars from this server.
you probably want to file this in calendar product :)
Severity: normal → major
Component: Untriaged → Provider: CalDAV
Product: Thunderbird → Calendar
Version: 38 Branch → unspecified
Hello Wayne,
thank you for your help (since lightning is now included in TB, I thought it was the same product)
Regards,
I could eventually identify the entries crashing TB, accessing the calendar server (communigate pro) without ssl and dumping the network traffic. We thus removed from the user's calendar the last event displayed in the dump. Have no idea what this entry had special :/
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
> Have no idea what this entry had special :/

I think that would make this bug "incomplete", because although we know how it was caused, we do not know why.
Unless you think the problem was caused by the server - in which case the status could be changed to "invalid".
If you wish to pursue it further feel free to post more information
Keywords: perf
Resolution: WONTFIX → INCOMPLETE
Could you post the event that causes the problem?
> I think that would make this bug "incomplete"

you're right

> Could you post the event that causes the problem?

I asked our mail provider to restore the whole calendar (but calendar only) at a date before I deleted those events to another account so that we could look for the cause, but against my expectations TB could display them without crashing ! This is driving me nuts...

So I just asked for a full restore to reproduce the bug, and I will keep you informed when done

Thanks again
Despite the whole account (mail + calendar) was restored to the date we encountered the bug, I cannot reproduce TB crashes : it can display correctly all the user's events without high CPU usage and no window freeze.

> Unless you think the problem was caused by the server - in which case the status could be changed to "invalid".

I now think so, but except restoring the user's mailbox I had no support from our mail provider :/

Anyway, thank you for your help, if I or my coworkers ever meet this issue again we will reopen this ticket.
Resolution: INCOMPLETE → INVALID
Hi Stefan, Wayne.

Sorry for the delay, I could eventually isolate the guilty event. 

I notice it also crashes TB when I add it as a calendar (new calendar/network/ICS/path : file:///...../cgpitem572.ics)

As i am not able to attach a file with the current ticket's status (invalid) I paste hereafter its content.

Thank you for your help.



BEGIN:VCALENDAR
PRODID:CommuniGate Pro 6.1.12
VERSION:2.0
BEGIN:VEVENT
ORGANIZER;CN="Jane DOE":MAILTO:janedoe@eauxdevienne.fr
DTSTAMP:20161103T125947Z
UID:721553214.246.janedoe
SEQUENCE:1
SUMMARY:TestSUMMARY
LOCATION:ton bureau
DTSTART:20150930T062000Z
DTEND:20150930T072000Z
ATTENDEE;cn="johndoe@eauxdevienne.fr","johndoe@eauxdevienne.fr";partstat=NEEDS-ACTION;role=REQ-PARTICIPANT;rsvp=true;CN="johndoe@eauxdevienne.fr":MAILTO:johndoe@eauxdevienne.fr
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
LAST-MODIFIED:20150924T145349Z
CREATED:20150924T145349Z
PRIORITY:5
END:VEVENT
END:VCALENDAR
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
The sample confirms that is is the known hang from bug 875739 that is currently fixed in Lightning 5.2 and newer.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875739
You need to log in before you can comment on or make changes to this bug.