Closed Bug 129083 Opened 23 years ago Closed 23 years ago

Right click on snowmobile picture causes reproduceable crash [@ XULPopupListenerImpl::FireFocusOnTargetContent]

Categories

(Core :: XUL, defect)

x86
Windows 98
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 129980

People

(Reporter: JWBohrer, Assigned: asa)

References

()

Details

(Keywords: crash)

Crash Data

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    20020204

Right click on the snowmobile picture in the Yamaha news section.
http://www.yamaha-motor.com/news/news.asp

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.yamaha-motor.com/news/news.asp
2.Find snowmobile picture
3.Right click on it

Actual Results:  Illegal Operation Error

Expected Results:  Should have brought up context menu
worksforme, linux build 2002-03-04.
wfm with win2k build 20020304..
seems to work for me
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
wfm using build 2002030108 on Linux.
Reporter: Please always use severity level "critical" for crashes.

WFM. Build ID: 2002 03 05 08. Windows 2000.
WFM 2002030508/Win2K

If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck. Mozilla releases nightly and milestone builds with Full
Circle's Talkback (you can get latest build on:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/)
Talkback should catch most crashes and offer to send in a crash report.
Developers can retrieve that crash report and attach it to your bug report if
you provide either the Incident ID (you can get it by running the talkback
program from /components/talkback/). Thanks for your help in testing Mozilla and
reporting bugs.
Severity: major → critical
Keywords: crash
I did use it to send in the crash data, but the report may have been sorted to
the Netscape people because I changed my user agent to show me as using Netscape
6.2.1. In any event, this looks like something that only crashes me.
The Incident ID of the one I sent (it happened each time I tried it, but I only
sent on report) was TB3662940E
Stephen, should I ask you for TB3662940E?
Stephen, should I ask you for TB3662940E?
XULPopupListenerImpl::FireFocusOnTargetContent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULPopupListener.cpp,
line 331]
XULPopupListenerImpl::PreLaunchPopup
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULPopupListener.cpp,
line 305]
XULPopupListenerImpl::ContextMenu
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULPopupListener.cpp,
line 206]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1500]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3427]
nsXULElement::HandleChromeEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 4634]
GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 659]
nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 3069]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1890]
nsGenericHTMLElement::HandleDOMEventForAnchors
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 1317]
nsHTMLLinkElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLLinkElement.cpp,
line 342]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5856]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5776]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 387]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 344]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 344]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1910]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 850]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 867]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4433]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4683]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3368]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1112]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407) 
Marking as dupe of bug 129980 regarding stack signature (newer bug, but
confirmed). Reporter: If you disagree, please reopen this bug.

*** This bug has been marked as a duplicate of 129980 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Component: Browser-General → XP Toolkit/Widgets: Menus
Resolution: --- → DUPLICATE
Summary: Right click on snowmobile picture causes reproduceable crash → Right click on snowmobile picture causes reproduceable crash [@ XULPopupListenerImpl::FireFocusOnTargetContent]
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: doronr → xptoolkit.widgets
Crash Signature: [@ XULPopupListenerImpl::FireFocusOnTargetContent]
You need to log in before you can comment on or make changes to this bug.