importScripts() in a service worker should use same http cache bypass settings as top level SW script

RESOLVED DUPLICATE of bug 1290944

Status

()

Core
DOM: Service Workers
P3
normal
RESOLVED DUPLICATE of bug 1290944
2 years ago
a year ago

People

(Reporter: bkelly, Assigned: HoPang)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
There are a few cases where we force-bypass the http cache when loading a service worker script.  When we do this we also need to bypass the http cache for any importScripts() resources.

See:

https://github.com/slightlyoff/ServiceWorker/issues/894#issuecomment-236016465
Hi Ben, I guess this is something between P2 (fix in a few months) or P3 (backlog). I am setting P3 for now, but feel free to change it as you see fit. Thanks!
Priority: -- → P3
Assignee: nobody → bhsu
(Reporter)

Updated

a year ago
Blocks: 1290944
(Assignee)

Updated

a year ago
No longer blocks: 1290944
(Assignee)

Comment 2

a year ago
Implemented in 1290944 :)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: → bug 1290944
Duplicate of bug: 1290944
You need to log in before you can comment on or make changes to this bug.