Conn: Limited Available Bandwidth Makes Mozilla Skip Loading/Reloading Page

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

({helpwanted})

Trunk
x86
All
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This has been around a while. 2002030316.

I'm on POTS, and rarely get a connection good for more than 26K. If I am
downloading a binary(s) with another app and try to load a new or reload a page
in Mozilla, Mozilla will display a resolving host or other message on status
bar, but will fail to actually load anything before stopping and displaying the
"done" message on the status bar.

Comment 1

16 years ago
Confirming.  I can only connect at 14.4K, and I've been seeing this for a while
on Windows 98.

Particularly noticed this on www.google.com, www.imdb.com, and even saw it on
jabber.com.  These pages would load partially, then abort midstream.

I've also had problems with downloading nightlies on occasion, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
(Reporter)

Comment 2

16 years ago
2002031716 OS/2

Under same conditions, a popup now occurs instead of nothing at all: "an unknown
error occurred while attempting to load the requested page". Result remains the
same - no page loaded.

Comment 3

16 years ago
mrmazda,

Perhaps bug 131399 is masking this for now?
(Reporter)

Comment 4

16 years ago
Bug 131399? I don't see the relationship?

This bug is still a problem in 2002040908 for OS/2.

Comment 5

16 years ago
> Bug 131399? I don't see the relationship?

I believe that bug was causing the change of behavior you described in comment
#2.  It applied to the build you reported using and was a recent issue.  As it
is now fixed, it isn't really a problem.

Comment 6

16 years ago
mrmazda: any update from a Mozilla 1.1-ish build?
Keywords: helpwanted, perf
Summary: Limited Available Bandwidth Makes Mozilla Skip Loading/Reloading Page → Conn: Limited Available Bandwidth Makes Mozilla Skip Loading/Reloading Page
(Reporter)

Comment 7

16 years ago
I moved to broadband last month.

Comment 8

16 years ago
how do you feel about resolving this as invalid, since we can't test anymore?
(Reporter)

Comment 9

16 years ago
Pretty dumb, since comment #1 indicates the problem was not unique to me. I
probably can test this anyway, but not likely today. Others maybe can too. Try
downloading three or more ISO's at once with WGET, then using Mozilla
(Reporter)

Comment 10

16 years ago
Still broken as of 2002080908 (didn't use newer build due to bug 162985). I set
ppp connection to supercede broadband; Loaded a bunch of pages in tabs; set
three theads each downloading a different Mozilla binary; then hit the reload
button on Slashdot, Wired, and The Register tabs. When the throbber stopped, the
Wired tab was a mostly blank page with some discernable bottom frame content and
no scrollbars.

Comment 11

16 years ago
I can reproduce this with recent trunk builds (pre-1.1). This is a really bad
problem. To reproduce, download a big file on a dialup connection (I got all the
way up to 48000 bps using my Lucent Winmodem) then try to load or reload some
Google pages, including Google groups pages, with Mozilla. The big download
usually continues but the Google transfer dies and the page does not load. My
guess is that maybe we lack only a further tweak of HTTP timeout settings.
Hopefully this is right: setting component to Networking: HTTP and reassigning.

P.S. After a month's absence, I'm back on DSL now. (Boy, you gotta get broadband.)
P.P.S. This is not a perf issue. The problem is not slowness but the inability
to transfer a file under the described circumstances.
Assignee: new-network-bugs → darin
Component: Networking → Networking: HTTP
Keywords: perf → mozilla1.2
QA Contact: benc → httpqa

Comment 12

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
a lot has changed here.. new bug with new str would be needed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.