Complex frames do not display properly.

VERIFIED DUPLICATE of bug 14827

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 14827
20 years ago
10 months ago

People

(Reporter: macgyver, Assigned: pollmann)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] hyp-x@inf.bme.hu, )

Attachments

(1 attachment)

Reporter

Description

20 years ago
Complex frames, and tables within complex frames, aren't displaying properly.
Images don't line up right within them, and sometimes images don't line up at
all.  A reference page is http://economy.tos.net -- the blue borders/frames on
the page do not render properly.  If I can help in any way, feel free to contact
me.

Comment 1

20 years ago
I looked at http://economy.tos.net in both Communicator 4.08 and IE5 on
Windows 98 and the blue border images don't line up there either.

Updated

20 years ago
Whiteboard: [MAKINGTESTCASE]

Comment 2

20 years ago
1.)
There's a table problem in one of the bottom frames:
  http://images.tos.net/panels/panelbottomsd.html
The numbers are shown vertically instead of horizontally.
This is a quirk, NS4.x and IE doesn't break between images that are in a
table cell. This is already filed in another bug.

2.)
The vertical lines are not showing because (I think) the <IMG HEIGHT=100%>
doesn't work yet. I remember seeing a bug about this at least.
I'll look it up.

3.)
There's a problem with the main frame, there's always a horizontal scrollbar,
independently of the window's width.
I'll look into this, too, may file a separate bug.

For the reference I was using 1999-09-01-09 on Win98

Comment 3

20 years ago
Re: my own comments
Problem 1.
  is a duplicate of bug #4427
Problem 2.
  is a duplicate of bug #3916
Problem 3.
  I have a testcase:
---
<html>
<body marginwidth=0>
<table border width=100% align=left>
  <tr><td>text</td></tr>
</table>
</body>
</html>
---
The problem shows itself when
 - the table is (left)aligned
 - has 100% width
 - the marginwidth is smaller than 4
I think it has to do with the margin, recently introduced to left aligned
tables. I already commented about this margin in bug 6946, as I thought it
was unneccesary. Seems it's buggy too.
(This is a regression, newer than M9.)

Updated

20 years ago
Whiteboard: [MAKINGTESTCASE] → [TESTCASE] hyp-x@inf.bme.hu

Updated

20 years ago
Assignee: karnaze → troy

Comment 5

20 years ago
Troy, I'm not sure if you should get this or Kipp. Regarding item #3 in the 9/2
comments and attachment, the outer table is correctly returning a desired width
equal to what it was given, yet there are horizontal scroll bars. When the
align=left is removed, the outer table returns exactly the same values, but
there are no horizontal scroll bars. You need to get my latest changes to
nsTableOuterFrame.cpp and BasicTableLayoutStrategy.cpp to see this in the table
debug output (set in nsTableFrame.cpp).

  TO::Rfl en 02671030 rea=0 av=(9120,UC) comp=(9120,UC)
    T::Rfl en 02672F20 rea=0 av=(9120,UC) comp=(9120,UC)
    T::Rfl ex 02672F20 des=(9120,435)
  TO::Rfl ex 02671030 des=(9120,435)

Updated

20 years ago
Assignee: troy → kipp

Comment 6

20 years ago
The align=left makes it appear to be a floater issue, so I'm assigning to Kipp

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

20 years ago
Assignee: kipp → karnaze
Status: ASSIGNED → NEW

Comment 7

20 years ago
I fixed #3; the reamining issues are either tables or framesets, not sure
which...back to you chris.

Updated

20 years ago
Assignee: karnaze → peterl

Comment 8

20 years ago
Peter, I tried looking at the problem reported on
http://images.tos.net/panels/panelbottomsd.html and got the following.

NTDLL! DbgBreakPoint@0 address 0x77f76148
nsDebug::Break(const char * 0x0162d66c, int 1122) line 155
nsDebug::Assertion(const char * 0x0162d6b4, const char * 0x0162d6a4, const char
* 0x0162d66c, int 1122) line 181 + 13 bytes
HTMLStyleSheetImpl::DropMappedAttributes(HTMLStyleSheetImpl * const 0x01d4aba0,
nsIHTMLMappedAttributes * 0x01da9350) line 1122 + 34 bytes
nsHTMLMappedAttributes::ReleaseUse(nsHTMLMappedAttributes * const 0x01da9350)
line 624
HTMLAttributesImpl::Reset(HTMLAttributesImpl * const 0x01da93b0) line 1447
HTMLAttributesImpl::~HTMLAttributesImpl() line 924
HTMLAttributesImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
HTMLAttributesImpl::Release(HTMLAttributesImpl * const 0x01da93b0) line 948 +
142 bytes
ReleaseAttributes(nsIHTMLAttributes * & 0x01da93b0) line 263 + 16 bytes
nsGenericHTMLElement::~nsGenericHTMLElement() line 274 + 12 bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2334 + 20
bytes
nsHTMLMapElement::~nsHTMLMapElement() line 214 + 11 bytes
nsHTMLMapElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLMapElement::Release(nsHTMLMapElement * const 0x01da9470) line 218 + 102
bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsHTMLTableCellElement::~nsHTMLTableCellElement() line 143 + 11 bytes
nsHTMLTableCellElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLTableCellElement::Release(nsHTMLTableCellElement * const 0x01d0df50) line
147 + 99 bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsHTMLTableRowElement::~nsHTMLTableRowElement() line 243 + 11 bytes
nsHTMLTableRowElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLTableRowElement::Release(nsHTMLTableRowElement * const 0x01c9b6d0) line
247 + 102 bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsHTMLTableSectionElement::~nsHTMLTableSectionElement() line 116 + 11 bytes
nsHTMLTableSectionElement::`scalar deleting destructor'(unsigned int 1) + 15
bytes
nsHTMLTableSectionElement::Release(nsHTMLTableSectionElement * const 0x01d799a0)
line 120 + 99 bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsHTMLTableElement::~nsHTMLTableElement() line 348 + 11 bytes
nsHTMLTableElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLTableElement::Release(nsHTMLTableElement * const 0x01d781b0) line 352 +
102 bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsBodyInner::~nsBodyInner() line 138 + 8 bytes
nsHTMLBodyElement::~nsHTMLBodyElement() line 569 + 11 bytes
nsHTMLBodyElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLBodyElement::Release(nsHTMLBodyElement * const 0x01d74280) line 573 + 102
bytes
nsGenericHTMLContainerElement::~nsGenericHTMLContainerElement() line 2332 + 12
bytes
nsHTMLHtmlElement::~nsHTMLHtmlElement() line 99 + 11 bytes
nsHTMLHtmlElement::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsHTMLHtmlElement::Release(nsHTMLHtmlElement * const 0x01d4b900) line 103 + 99
bytes
nsDocument::~nsDocument() line 688 + 27 bytes
nsMarkupDocument::~nsMarkupDocument() line 47 + 8 bytes
nsHTMLDocument::~nsHTMLDocument() line 248 + 23 bytes
nsHTMLDocument::`scalar deleting destructor'() + 15 bytes
nsDocument::Release(nsDocument * const 0x01d4ae80) line 813 + 103 bytes
nsHTMLDocument::Release(nsHTMLDocument * const 0x01d4ae80) line 288
nsCOMPtr<nsIDocument>::~nsCOMPtr<nsIDocument>() line 458
DocumentViewerImpl::~DocumentViewerImpl() line 294 + 66 bytes
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x01d4ac40) line 236 + 99
bytes
nsWebShell::Destroy(nsWebShell * const 0x019a3a60) line 1141 + 27 bytes
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 472
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x019a2da0, nsIPresContext & {...}) line 347 +
34 bytes
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x019a1c10, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x019a0b00, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0199fbb0, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0199c300, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0199b820, nsIPresContext &
{...}) line 88
nsLineBox::DeleteLineList(nsIPresContext & {...}, nsLineBox * 0x0199b760) line
161
nsBlockFrame::Destroy(nsBlockFrame * const 0x0199a360, nsIPresContext & {...})
line 978 + 16 bytes
nsAreaFrame::Destroy(nsAreaFrame * const 0x0199a360, nsIPresContext & {...})
line 111
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0199acd0, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x01999240, nsIPresContext &
{...}) line 88
ViewportFrame::Destroy(ViewportFrame * const 0x01999240, nsIPresContext & {...})
line 134
PresShell::~PresShell() line 511
PresShell::`scalar deleting destructor'() + 15 bytes
PresShell::Release(PresShell * const 0x019945a0) line 435 + 35 bytes
nsCOMPtr<nsIPresShell>::~nsCOMPtr<nsIPresShell>() line 458
DocumentViewerImpl::~DocumentViewerImpl() line 294 + 22 bytes
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x0196bca0) line 236 + 99
bytes
nsWebShell::Destroy(nsWebShell * const 0x017861d0) line 1141 + 27 bytes
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 472
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x01786470, nsIPresContext & {...}) line 347 +
34 bytes
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x01763f60, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x017608d0, nsIPresContext &
{...}) line 88
nsLineBox::DeleteLineList(nsIPresContext & {...}, nsLineBox * 0x01760860) line
161
nsBlockFrame::Destroy(nsBlockFrame * const 0x01763760, nsIPresContext & {...})
line 978 + 16 bytes
nsAreaFrame::Destroy(nsAreaFrame * const 0x01763760, nsIPresContext & {...})
line 111
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0175e7d0, nsIPresContext &
{...}) line 88
nsFrameList::DestroyFrames(nsIPresContext & {...}) line 29
nsContainerFrame::Destroy(nsContainerFrame * const 0x0175ec20, nsIPresContext &
{...}) line 88
ViewportFrame::Destroy(ViewportFrame * const 0x0175ec20, nsIPresContext & {...})
line 134
PresShell::~PresShell() line 511
PresShell::`scalar deleting destructor'() + 15 bytes
PresShell::Release(PresShell * const 0x01751f10) line 435 + 35 bytes
nsCOMPtr<nsIPresShell>::~nsCOMPtr<nsIPresShell>() line 458
DocumentViewerImpl::~DocumentViewerImpl() line 294 + 22 bytes
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x00e935b0) line 236 + 99
bytes
nsWebShell::Embed(nsWebShell * const 0x00e591f0, nsIContentViewer * 0x01e45ef0,
const char * 0x00000000, nsISupports * 0x00000000) line 855 + 27 bytes
nsDocumentBindInfo::OnStartRequest(nsDocumentBindInfo * const 0x01e46a90,
nsIChannel * 0x01e45ba0, nsISupports * 0x00000000) line 1298 + 36 bytes
nsChannelListener::OnStartRequest(nsChannelListener * const 0x01e467e0,
nsIChannel * 0x01e45ba0, nsISupports * 0x00000000) line 1549 + 43 bytes
nsHTTPResponseListener::FinishedResponseHeaders() line 680 + 37 bytes
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x01e46980, nsIChannel * 0x01e44280, nsISupports * 0x01e45ba0, nsIInputStream *
0x01e42eb8, unsigned int 0, unsigned int 802) line 166 + 8 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x01e45080)
line 359
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x01e44040) line 152 + 12 bytes
PL_HandleEvent(PLEvent * 0x01e44040) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00e37350) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x003c04b6, unsigned int 49371, unsigned int 0,
long 14906192) line 970 + 9 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsNativeViewerApp::Run() line 74
main(int 1, char * * 0x00b115c0) line 136 + 11 bytes
mainCRTStartup() line 338 + 17 bytes

Updated

20 years ago
Assignee: peterl → karnaze

Comment 9

20 years ago
Assertion fixed, back to you...

Comment 10

20 years ago
For #2 (vertical lines not showing) I found another problem.
This is a document.write problem, and I reported this in bug 14700.

BUT, I found a frame problem too!
SCROLLING="NO" doesn't work. It doesn't disable scrolling.

Updated

20 years ago
Assignee: karnaze → pollmann

Comment 11

20 years ago
I fixed the table problem mentioned at
http://images.tos.net/panels/panelbottomsd.html

Eric, can you look at the remaining frameset problems.

Updated

20 years ago
QA Contact: beppe → petersen
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Assignee

Comment 12

20 years ago
This is a recent regression, bug 14827

*** This bug has been marked as a duplicate of 14827 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 13

20 years ago
Agreed. Marking as a verified duplicate of 14827.

Updated

10 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.