Closed Bug 1291047 Opened 3 years ago Closed 3 years ago

Intermittent test_standards.py TestStandardsUnits.test_units | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360s)

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(firefox51 fixed)

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Whiteboard: [fixed by bug 1051567])

Duplicate of this bug: 1291119
Component: web-platform-tests → Marionette
Version: Version 3 → unspecified
Summary: Intermittent test_standards.py TestStandardsUnits.test_units | TimeoutException: TimeoutException: Process killed because the connection was lost (Reason: TimeoutException: Connection timed out) → Intermittent test_standards.py TestStandardsUnits.test_units | TimeoutException: Process killed because the connection was lost (Reason: TimeoutException: Connection timed out)
The failure signature has been changed. Reflecting this in the bug summary.
Summary: Intermittent test_standards.py TestStandardsUnits.test_units | TimeoutException: Process killed because the connection was lost (Reason: TimeoutException: Connection timed out) → Intermittent test_standards.py TestStandardsUnits.test_units | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360s)
Excerpt from gecko.log:

1470491651165	Marionette	TRACE	conn178 -> [0,11,"findElement",{"using":"id","value":"complete"}]
[Child 2374] WARNING: 'NS_FAILED(res)', file /builds/slave/fx-team-m64-d-0000000000000000/build/src/editor/libeditor/EditorBase.cpp, line 663
Assertion failure: fallibleScope_ ([OOM] Cannot allocate a new chunk in an infallible scope.), at /builds/slave/fx-team-m64-d-0000000000000000/build/src/js/src/ds/LifoAlloc.cpp:105

###!!! [Parent][MessageChannel] Error: (msgtype=0x2E007D,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

Same underlying issue as bug 1294540. Marking as dependent.
Depends on: 1294540
Whiteboard: [blocked by bug 1294540]
This crash should be fixed now with the patch on bug 1051567 landed (not bug 1294540).
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1051567
No longer depends on: 1294540
Resolution: --- → FIXED
Whiteboard: [blocked by bug 1294540] → [fixed by bug 1051567]
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.