Closed Bug 12912 Opened 20 years ago Closed 20 years ago

HTTP REDIRECT command misinterpreted for relative links

Categories

(Core :: HTML: Parser, defect, P3, major)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 10647

People

(Reporter: grega.bremec, Assigned: gagan)

References

Details

A code such as the following, loaded from http://some.domain.com/someurl

<html><head>
	<title>blah blah</title>
	<meta http-equiv="refresh" content="0; URL=./here">
</head><body ...>
</body></html>

Fails to correctly redirect the browser to http://some.domain.com/someurl/here,
but rather redirects it to http://some.domain.com/here

The code was executed in the M9 release (1999082414), running on Linux 2.2.1, the
connection was to an Apache 1.3.3 HTTP server running on RedHat.

AFAIK, this bug does not apply to any of the currently available Navigator or
Exploder versions.
Assignee: rickg → warren
Warren: I'm giving this to under the impression that URL handling (including
redirects) are yours. Please correct me if I'm mistaken.
Assignee: warren → gagan
Blocks: 13449
Sounds like a URL parsing problem. -> Gagan (or Andreas)
This is the same problem as in bug 10647, where I described how a possible
solution could be done
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Yes we need to update the location bar with a trailing slash for directory
cases. Marking duplicate of 10647.

*** This bug has been marked as a duplicate of 10647 ***
Status: RESOLVED → VERIFIED
verified
You need to log in before you can comment on or make changes to this bug.