nsAtomTable is not thread safe

VERIFIED DUPLICATE of bug 12755

Status

()

Core
XPCOM
P2
normal
VERIFIED DUPLICATE of bug 12755
18 years ago
12 years ago

People

(Reporter: dougt, Assigned: Edward Kandrot)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
the constructor and desstructor of nsAtomTable are not thread safe.  see:
http://bugzilla.mozilla.org/show_bug.cgi?id=12755

Comment 1

18 years ago
All of the NS_NewAtom methods need to be threadsafe too, not just the
creation/destruction of the hashtable that those methods use.

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Blocks: 12755

Updated

18 years ago
Target Milestone: M16

Comment 2

18 years ago
as with 12755, awaiting CoClasses, I think

Updated

18 years ago
Priority: P3 → P2

Updated

18 years ago
Target Milestone: M16 → Future

Comment 3

18 years ago
mass re-assigning to my new bugzilla account
Assignee: scc → scc
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

17 years ago
dp is no longer @netscape.com. changing qa contact to default for this product
QA Contact: dp → kandrot
dup of bug 12755, it seems.  scc, please mark dup?

/be

Comment 6

17 years ago
another threads bug.  I hate to dump on you, but I'll be focusing on strings.
If you don't want to take threading, we can discuss it at tomorrows XPCOM bug
meeting and figure out what to do.
Assignee: scc → kandrot
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
QA Contact: kandrot → scc
(Assignee)

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 12755 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.