Wavey davey animation no longer repeats when running on main thread

RESOLVED DUPLICATE of bug 1287122

Status

()

Core
DOM: Animation
P1
normal
RESOLVED DUPLICATE of bug 1287122
2 years ago
a year ago

People

(Reporter: birtles, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50- fixed, firefox51 fixed)

Details

(URL)

(Reporter)

Description

2 years ago
In [1] there is an animation that runs on main thread and the compositor. On Firefox 51 the main thread version stops after the first iteration. On Firefox 49 it repeats as expected.

[1] http://people.mozilla.org/~bbirtles/bugs/1223658/wavey-davey.html
(Reporter)

Updated

2 years ago
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox50: --- → ?
(Reporter)

Comment 2

2 years ago
Thanks Alice!
(Reporter)

Comment 3

2 years ago
Matt, does this look like something bug 1282312 might have caused?
Flags: needinfo?(matt.woodrow)
status-firefox50: ? → affected

Comment 4

2 years ago
(In reply to Alice0775 White from comment #1)
> Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=0d0a2960686a335eb09de6edbe1dfe573e212701&tochange=0987
> 4746f3e0ef2a2566e6ae5916456fed84841a
> 
> Suspect : Bug 1282312

Via local build,
Last Good: 0d0a2960686a
First Bad: 2bd88c9c8068
[Tracking Requested - why for this release]: regression
tracking-firefox50: --- → ?
tracking-firefox51: --- → ?
Tracking 51+ for this animation regression.
tracking-firefox51: ? → +
Changing blocking bug number based on comment 4.
Blocks: 1281428
No longer blocks: 1282312
I can reproduce comment 0 in today's 50 build (I apparently can't edit the affected field).
(Reporter)

Comment 9

2 years ago
(In reply to Andrew Overholt [:overholt] from comment #8)
> I can reproduce comment 0 in today's 50 build (I apparently can't edit the
> affected field).

status-firefox50 should already be set to affected. Was there some other field we need to tweak? tracking-firefox50?
This is fixed on Nightly, I believe due to bug 1287122. That's just been approved for Aurora too.
(Reporter)

Comment 11

2 years ago
Works for me in Nightly and Aurora now (although I get flicker in both versions on Nightly now).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
status-firefox51: affected → fixed
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1287122
The other bug is tracked and fixed in 50, no need to track this one.
tracking-firefox50: ? → -
tracking-firefox51: + → ---
You need to log in before you can comment on or make changes to this bug.