Closed Bug 1292165 Opened 8 years ago Closed 8 years ago

Unexpected "System Unsupported" popup on OSX Lion

Categories

(Toolkit :: Application Update, defect)

48 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: stuartd, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160803030226

Steps to reproduce:

Nothing - just browsing


Actual results:

System Unsupported

Your Firefox is out of date, but the latest version is not supported on your system. Please upgrade your system, then try again. You will not see this notice again, but you can learn more.


Expected results:

Not to receive the popup: Firefox 48 is not (at the time of this submission) out of date.
Happened again just now: there was an upgrade notification which I clicked out of habit without thinking (as a longtime nightly build user does) - next time I'll try to get a screenshot of the notification.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:48.0) Gecko/20100101 Firefox/48.0

I have tested this issue on Mac OS 10.7 with the latest Firefox release (48.0) and managed to reproduce it.
After Firefox was installed and I have browsed for a while, the popup with the "System Unsupported" notification appeared showing the same message. 
"Your Firefox is out of date, but the latest version is not supported on your system. Please upgrade your system, then try again. You will not see this notice again, but you can learn more."
Status: UNCONFIRMED → NEW
Component: Untriaged → Application Update
Ever confirmed: true
Product: Firefox → Toolkit
Ben, is the unsupported advertisement already published to Firefox 48 users?
Flags: needinfo?(bhearsum)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #4)
> Ben, is the unsupported advertisement already published to Firefox 48 users?

Yes, we enabled the deprecation notice as part of shipping 49.0. This is what we wanted to do, isn't it?
Flags: needinfo?(bhearsum)
Ben, but we aren't shipping Firefox 49 yet. We should notify users that their Firefox is out of date and can't be upgraded when it actually is.
Flags: needinfo?(bhearsum)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #6)
> Ben, but we aren't shipping Firefox 49 yet. We should notify users that
> their Firefox is out of date and can't be upgraded when it actually is.

Okay. I spelled out this plan over in https://bugzilla.mozilla.org/show_bug.cgi?id=1269811#c24, but clearly it wasn't quite right for Release and ESR. I've removed the desupport rule for Release.

I'll tweak our notes to do the desupport part just before the first unsupported version ships - and hopefully we don't forget. This should only apply to Release/ESR now, since 49.0 has shipped to other channels.

This acute issue should be fixed now.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(bhearsum)
Resolution: --- → FIXED
Thanks Ben! I didn't read the releng implementation and probably wouldn't have caught this if I did. I'm fine with whatever release drivers wants but my 2 cents are that we shouldn't be telling people the Firefox version they are using is no longer supported when it is.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: