Closed Bug 1292183 Opened 4 years ago Closed 4 years ago

[Windows 7] No hardware acceleration for decoding H.264 video

Categories

(Core :: Audio/Video: Playback, defect)

48 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: f2me, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

Updated from Firefox 47.0.x to 48.0


Actual results:

Apparently, since Firefox 48.0 my video drivers has been blacklisted for DXVA H.264 hardware acceleration. Now there's only software decoding available.

From about:support
------------------
Hardware decoding H264:	No; D3D9 blacklisted with DLL atiumd64.dll (9.14.10.1080)


Expected results:

I have Windows 7 x64 on AMD APU E-350 with integrated AMD Radeon HD 6310. Have never experienced any crashes, related to hardware accelerated HTML5 Video (MP4, H.264; Flash Player is not installed). Until Firefox 48.0 everything worked perfectly.

My video card AMD Radeon HD 6310 was declared as "legacy" not so long time ago, so there will be no new drivers available ever. I'm using Catalyst 14.12 Omega driver now, for which HW video acceleration suddenly became blacklisted if FF 48. The latest (i.e. the latest ever available) official Catalyst 15.7.1 and Crimson 16.2.1 Beta is blacklisted also. 

I was forced to install one of the ancient video drivers, from like 2011-2012 yr. just to get DXVA HW acceleration back in FF48.

Please, remove atiumd64.dll (9.14.10.1080) DLL from the blacklist, at least for Windows 7 x64. Otherwise (and very sadly), there will be no other option for me than to switch to another browser.
Component: Untriaged → General
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Component: General → Audio/Video
Product: Firefox → Core
I can absolutely confirm this issue in my HTPC application using a Radeon HD6670 - latest drivers on Windows 7. Worked flawlessly pre 48. Hardware H.264 decode is now broken (disabled) in Firefox causing extremely high cpu usage. Reverted to 47.0.1 for time being. Going through the other new thread on this issue, it seems to be impacting Nvidia cards as well on Windows 7. I hope this is resolved soon as working hardware video decoding is an absolute must in modern browser. I would prefer to stay with Firefox, but this is a long term deal breaker for my setup.
Component: Audio/Video → Audio/Video: Playback
While we're sorting this out, and since the original issue wasn't a security related problem, you can do about:config in the latest Firefox, type media.wmf.disable-d3d9-for-dlls in the search field, double click on the value, and remove 9.14.10.1080 from the list.  Restarting Firefox should give you the hardware video decoding back.
Milan, thanks very much for the update and workaround!
Thanks, Milan!
I confirm that HW video decoding works as before with this workaround. And still no crashes.
I'm going to close this as it works as intended.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Hi, is there a bug for tracking the enable of video decoding on Radeon HD cards? Till today, I still have to force-enable video decoding. Thanks.
Depends on: 1335925
You need to log in before you can comment on or make changes to this bug.