Memory leak in tstclnt - allocated by srtdup in tstclnt.c

RESOLVED DUPLICATE of bug 129218

Status

P3
normal
RESOLVED DUPLICATE of bug 129218
17 years ago
13 years ago

People

(Reporter: bishakhabanerjee, Assigned: bishakhabanerjee)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
Detected while running tstclnt on BoundsChecker

Memory leak
10 bytes allocated by strdup in tstclnt.c (331), HANDLE: 0x004B2E48

Location of Error
main
tstclnt.c
331
_mainCRTStartup
TSTCLNT.EXE!00007EFD
(unknown)
(Assignee)

Comment 1

17 years ago
Changed component to Tools.

main() of tstclnt.c calls strdup() to allocate
the string "host", but it is not freed.

Wan-Teh, should I assign myself this bug? This is similar to the others I filed
yesterday and were assigned to me.

Component: Test → Tools
(Assignee)

Comment 2

17 years ago
oops, forgot to add myself again

Comment 3

17 years ago
Assigned the bug to Bishakha.  Target 3.4.1, priority P2.
Assignee: sonja.mirtitsch → bishakhabanerjee
Priority: -- → P2
Target Milestone: --- → 3.4.1

Comment 4

17 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee

Comment 5

17 years ago
Set target milestone to NSS 3.5.
Target Milestone: 3.4.1 → 3.5

Updated

16 years ago
Priority: P2 → P3
Target Milestone: 3.5 → 3.7

Comment 6

16 years ago
Moved to target milestone 3.8 because the original
NSS 3.7 release has been renamed 3.8.
Target Milestone: 3.7 → 3.8
Remove target milestone of 3.8, since these bugs didn't get into that release.
Target Milestone: 3.8 → ---

*** This bug has been marked as a duplicate of 129218 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
QA Contact: bishakhabanerjee → jason.m.reid
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.