Closed Bug 1292250 Opened 4 years ago Closed 4 years ago

remove chrome use from devtools/client/sourceeditor/editor.js

Categories

(DevTools :: Framework, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1289425

People

(Reporter: tromey, Unassigned)

References

Details

Examination of the inspector startup sequence shows it loading
devtools/client/sourceeditor/editor.js, which uses chrome to get domutils.
It's not totally clear that we'll need this module, but on the other
hand it's reasonably easy to fix once getCSSPropertyNames is done.
Flags: qe-verify-
Priority: -- → P2
Whiteboard: [devtools-html] → [reserve-html]
This is already handled in the patches attached to bug 1289425.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1289425
No longer blocks: devtools-html-3
Priority: P2 → --
Whiteboard: [reserve-html]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.