Firefox works slow on a Gateway ZX4250




2 years ago
2 years ago


(Reporter: federico.d.schonborn, Unassigned, NeedInfo)


Firefox Tracking Flags

(Not tracked)



(1 attachment)



2 years ago
Created attachment 8778184 [details]
Hardware details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

Steps to reproduce:

Installed Firefox and used it, opened ~5 tabs only (Twitter, GitHub, a WebGit, Google+ and Distrowatch)

Actual results:

Firefox interface is too slow and interface freezes everytime, but webpage loading is really fast, I attached to this bug a file with all my hardware details

Expected results:

Comparing to less-powered PCs, in this machine Firefox should work without problems

Comment 1

2 years ago
To add: I experienced it since the Australis introduction, I'm not blaming the new interface :)


2 years ago
Summary: Firefox works slow on a ZX4250 since Australis → Firefox works slow on a Gateway ZX4250


2 years ago
Group: firefox-core-security
User Agent: Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0

I have tested this issue on Ubuntu 12.04 x32 with the latest Firefox release (48.0.2) and the latest Nightly (51.0a1-20160831030224) and could not reproduce it.
After navigating to different websites (eg: Youtube, Reddit, Github, Google+, etc) I haven't exprienced any hangs, loading issues or freezes.
Due to the fact that we don't have any slow PCs, simillar to the one which you are using, for now, we might not be able to properly test this.
However, you can find some tweaks on this page ( that might help you improve Firefox's speed.

Can you please try retest this using the latest Firefox release and the latest Nightly build ( and report back the results? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (

Also please try to describe in details the issues you are encountering, image rendering issues, hangs, scrolling issues or any other problems that you are experiencing while using firefox.
Flags: needinfo?(federico.d.schonborn)
Marking this as Resolved - Incomplete due to the lack of response from the reporter.

If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.